Bug Hunting Session
Bug 126846 - Rendering issue when using GTK2 VCL
Summary: Rendering issue when using GTK2 VCL
Status: RESOLVED DUPLICATE of bug 127327
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-12 10:40 UTC by Max A. Dednev
Modified: 2019-09-08 20:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Toolbar icons missing (29.59 KB, image/png)
2019-08-17 14:33 UTC, Ray-V
Details
Tip of the Day (17.69 KB, image/png)
2019-08-17 14:38 UTC, Ray-V
Details
About dialogue box (25.33 KB, image/png)
2019-08-17 14:38 UTC, Ray-V
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max A. Dednev 2019-08-12 10:40:02 UTC
Description:
I'm using Debian Jessie with latest updates:

Distributor ID: Debian
Description:    Debian GNU/Linux 8.11 (jessie)
Release:        8.11
Codename:       jessie

I've successfully installed LibreOffice 6.3 release and when I tried to look at "About..." I've got following black dialog box: https://snag.gy/oVewMz.jpg

Another issue is "Tip of the day" dialog box (look at black rectangle): https://snag.gy/Y2mnNW.jpg

I've tried to start LO in safe mode, but this doesn't help. OpenGL is disabled.

Steps to Reproduce:
1. Install LibreOffice 6.3 on Debian Jessie 8.11
2. Start LibreOffice
3. Select Help=>About...

Actual Results:
Black background on "About" dialog box.

Expected Results:
Correct background color in dialog box.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (C); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-08-12 11:49:00 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: 2812610f4f39ed5892da08864893c758325d1d39
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

which version of GTK are you using ?
Comment 2 Max A. Dednev 2019-08-13 10:19:06 UTC
I've checked this for 6.4.0:

Version: 6.4.0.0.alpha0+
Build ID: 8387a6db641b29e6ff3c2f4cdc4688f538cbe35f
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-08-09_06:28:42
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Result is exactly the same: black background.

GTK2 version info:
[makc@maximus DEBS]$ dpkg -l |grep libgtk2
ii  libgtk2-perl                                                2:1.2492-4                                  amd64        Perl interface to the 2.x series of the Gimp Toolkit library
ii  libgtk2.0-0:amd64                                           2.24.25-3+deb8u2                            amd64        GTK+ graphical user interface library
ii  libgtk2.0-0:i386                                            2.24.25-3+deb8u2                            i386         GTK+ graphical user interface library
ii  libgtk2.0-bin                                               2.24.25-3+deb8u2                            amd64        programs for the GTK+ graphical user interface library
ii  libgtk2.0-common                                            2.24.25-3+deb8u2                            all          common files for the GTK+ graphical user interface library
ii  libgtk2.0-dev                                               2.24.25-3+deb8u2                            amd64        development files for the GTK+ library
Comment 3 Ray-V 2019-08-17 14:33:46 UTC
Created attachment 153461 [details]
Toolbar icons missing
Comment 4 Ray-V 2019-08-17 14:37:01 UTC
I'll add my bug report here, although it includes an issue with toolbar icons and applies with gen vcl as well as gtk, and my OS is Slackware-current ..

The toolbar icons for Background|Border|Font Colour do not display in LibreOffice 6.3.0.4.

I've tried the release, and building it myself, and the issue is the same in both.

I had previously built v6.2.5.1 which does display these icons OK, and used the same configure options for the v6.3.0.4 build. But as the release has the same issues, I'm suspecting that the problem is due to something that changed between 6.2 and 6.3.

Using any theme, the icons show the border rectangle with the colour bar at the bottom, but the images [cmd/lc_{background,frameline,font}color.png] aren't displaying. The menu items function as they should - see attachment.

Other icons/images not displaying:
The Help/About dialogue box is just a black rectangle with buttons at the bottom, and the Tip of the Day box shows a black rectangle where I presume an image should be displayed - see attachments. The About box highlighting is to demonstrate that the text is there, it's just the image that's not displaying.

In Draw - Line Colour and Fill Colour icons and the rotation image don't display, and the line width selection drop-down menu flickers. However, all functions work.
Comment 5 Ray-V 2019-08-17 14:38:05 UTC
Created attachment 153462 [details]
Tip of the Day
Comment 6 Ray-V 2019-08-17 14:38:52 UTC
Created attachment 153463 [details]
About dialogue box
Comment 7 Ray-V 2019-08-23 14:58:12 UTC
Just providing an update on the bugs affecting me.

I've tried:
libreoffice-6-3~2019-08-20_14.33.16_LibreOfficeDev_6.3.2.0.0_Linux_x86-64
Build ID: ff3cfee4ebfcb412f54f17ffccc95512fdc15c8e
VCL: gtk2;

and

master~2019-08-21_09.30.10_LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64
Build ID: 2bed8af91fc2654b9ed2432f969d32d5741a529b
VCL: gtk2;

and the About dialogue displays OK.

Still have the bugs with Tip of the Day, the toolbar Colour icons, and Draw.
Using gtk+2-2.24.32
Comment 8 Aron Budea 2019-08-25 03:14:51 UTC
Seems like the issue with the about box was bug 126254, but it seems the fix there didn't help the others. Caolán, by any chance are you able to see these in the VM as well?
Comment 9 Caolán McNamara 2019-09-05 11:29:21 UTC
as an aside I wonder why people are still using the gtk2 vclplug

*** This bug has been marked as a duplicate of bug 127327 ***
Comment 10 Max A. Dednev 2019-09-05 11:35:10 UTC
(In reply to Caolán McNamara from comment #9)
> as an aside I wonder why people are still using the gtk2 vclplug

Debian Jessie is still here. :-)
gtk3 VCL plugin doesn't work:

$ libreoffice6.3
/opt/libreoffice6.3/program/soffice.bin: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.3/program/libmergedlo.so)

** (process:10606): WARNING **: require gtk >= 3.18 for theme expectations
/opt/libreoffice6.3/program/soffice.bin: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.3/program/libmergedlo.so)

** (process:10615): WARNING **: require gtk >= 3.18 for theme expectations
Comment 11 Ray-V 2019-09-08 20:30:53 UTC
I've tried:
master~2019-09-07_10.36.29_LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64

| Version: 6.4.0.0.alpha0+
| Build ID: c1e1806c9c01d2ac2f62f95dd79cbb2037bc87af
| CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
| TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-09-07_10:36:29
| Locale: en-GB (en_GB.utf8); UI-Language: en-GB
| Calc: threaded

This fixes all the issues I've reported, except for the flickering Draw|line|width dropdown.
The drop down display flickers with LO 6.3.x and 6.4.x on x86_64, but is OK with LO 6.2.x, and I've built 6.3.0.4 for aarch64 and it's OK on that.

I've also built 6.3.0.4 with the patches applied [https://bugs.documentfoundation.org/show_bug.cgi?id=125461#c8], for gen vclplugin, and the issues are fixed in that too, except for the flickering ...

Q] as an aside I wonder why people are still using the gtk2 vclplug

A] Because I prefer the gtk2 interface.