Bug Hunting Session
Bug 126848 - Drop-down filter window in Pivot table is flickering when move mouse point on it
Summary: Drop-down filter window in Pivot table is flickering when move mouse point on it
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.4.0 target:6.3.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Flickering-UI
  Show dependency treegraph
 
Reported: 2019-08-12 11:37 UTC by Roman Kuznetsov
Modified: 2019-08-14 07:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example with Pivot (10.60 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-08-12 11:38 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-08-12 11:37:15 UTC
Description:
Drop-down filter window in Pivot table is flickering when move mouse point on it

Strange to see it after fix of bug 101086

Steps to Reproduce:
0. make sure you have disabled OpenGL
1. Open file from attach
2. Go to Pivot tab
3. Open drop-down filter in A1 cell "Трава"
4. Move mouse point on filter window => look at flickering

Actual Results:
Drop-down filter window in Pivot table is flickering

Expected Results:
Drop-down filter window in Pivot table isn't flickering


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: ca6df519a78e5bfc96030c916f242b86306194e5
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-08-12 11:38:47 UTC
Created attachment 153320 [details]
Example with Pivot
Comment 2 Xisco Faulí 2019-08-13 11:25:44 UTC
it seems to be another case not fixed by the commit fixing bug 101086
I can reproduce it in gen/gtk2

Version: 6.4.0.0.alpha0+
Build ID: 2812610f4f39ed5892da08864893c758325d1d39
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Commit Notification 2019-08-13 15:50:26 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1352b1fcfa1668081c3197a12d5362286f8f9710%5E%21

tdf#126848: sc pivot table popup: avoid flicker

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-08-14 07:05:12 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/f6c78ee996e87c8f7f0d162e06bc2ce6c7633481%5E%21

tdf#126848: sc pivot table popup: avoid flicker

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.