Bug 126854 - Horizontal scrolling inverse under macOS
Summary: Horizontal scrolling inverse under macOS
Status: RESOLVED DUPLICATE of bug 126680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-12 15:02 UTC by Wojtek
Modified: 2019-08-12 17:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wojtek 2019-08-12 15:02:47 UTC
Description:
Scrolling spreadsheet in x-axis is inversed, while y-axis is OK

Steps to Reproduce:
1.open spreadsheet
2.using touchpad two-finger gesture to scroll try to scroll horizontally to the right (i.e. drag fingers to the left - this is more like on smartphones screen)
3.

Actual Results:
No scrolling whatsoever. But if we drag to the right, the view scrolls.



Expected Results:
When dragging to the right the view should scroll/shift to the left.

It looks like for x-axis for some reason Calc ignores the system and scroll is like 'mousescroll', which moves scrollbar instead of view.

It works correctly for y-axis (dragging fingers down scrolls the view up)


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no

Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 8; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: pl-PL (es_PL.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 V Stuart Foote 2019-08-12 17:56:39 UTC

*** This bug has been marked as a duplicate of bug 126680 ***