Bug 126914 - Calc does not highlight the current cell or cell range (gtk/gtk3)
Summary: Calc does not highlight the current cell or cell range (gtk/gtk3)
Status: RESOLVED DUPLICATE of bug 125720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: GTK3 GTK2
  Show dependency treegraph
 
Reported: 2019-08-14 10:01 UTC by Steffen
Modified: 2019-10-19 08:20 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Wrong active cell highlighting (128.01 KB, image/png)
2019-08-14 15:17 UTC, Steffen
Details
Example file: Cell-highlighting-bug.ods (20.45 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-08-27 11:30 UTC, WernerFP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen 2019-08-14 10:01:12 UTC
Description:
The current cell or cell range is not highlighted in the spreadsheet view.

Actual Results:
No actions needed - the bug occurs after program start

Expected Results:
No results (see above)


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
When the window is minimized and restored (a redraw forced?) the current cell is highlighted correctly. The bug also appears in safe mode.
Comment 1 Steffen 2019-08-14 15:11:53 UTC
I checked the problem on other spreadsheets. It looks like the current cell/cell range is not highlighted WHEN the grid is set off.
Comment 2 Steffen 2019-08-14 15:17:20 UTC
Created attachment 153389 [details]
Wrong active cell highlighting
Comment 3 Steffen 2019-08-14 15:19:44 UTC
Comment on attachment 153389 [details]
Wrong active cell highlighting

In the screenshot C7 is active, but F13 highlighted. This changes e.g. after resizing the window. 
The behavior is independent of grid visibility.
Comment 4 IM 2019-08-20 22:59:15 UTC
Thank you for reporting the bug. I can not reproduce the bug in:

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 5c30c20101f72d973ff28c228f755e635cad14d5
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded

Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded
Comment 5 raal 2019-08-21 05:46:01 UTC
No repro with Version: 6.4.0.0.alpha0+
Build ID: 35b41150e84940e87b9d961b6b402e3e060d6b8b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

Please copy and paste here the contents of your Help - About from your LibreOffice. This allows us to know more about your system.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 6 WernerFP 2019-08-27 11:30:16 UTC
Created attachment 153685 [details]
Example file: Cell-highlighting-bug.ods
Comment 7 WernerFP 2019-08-27 11:33:39 UTC
Comment on attachment 153685 [details]
Example file: Cell-highlighting-bug.ods

We can confirm this problem.
The problem occurs in LO Calc 6.3.0.4 for Linux (in our company Arch Linux and Debian Testing), Windows 10 is not affected.

The sample file (see above) contains 2 sheets:

1. sheet = Bug present

After opening the file, the last selected cell is highlighted. If another cell is then selected, the highlighting is not updated.
The newly selected cell is not highlighted, but it is active. If you write to the cell, the cursor flickers hectically.

2. sheet = Bug not present

Strange: Here the cell selection is updated as expected. The only difference is that the push buttons have been deleted.
Comment 8 Xisco Faulí 2019-09-03 10:59:35 UTC
@WernerFP, thanks for providing the file!

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d464d505fbf6e53a38afdd3661d320fac8c760d6

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-10-12 11:13:09 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-11-27 11:33:10 +0100
commit	d464d505fbf6e53a38afdd3661d320fac8c760d6 (patch)
tree	3bf7db8591172bf948198f19d36df5df886486bb
parent	3e1e2b6687b0259ae28441cc0d314de0d908776b (diff)
Refactor calc non-linear ViewToDevice transform

Bisected with: bibisect-linux64-6.3

Adding Cc: to Armin Le Grand
Comment 9 Xisco Faulí 2019-09-03 11:02:43 UTC
GTK and GTK3 only. @Caolán, I thought you might be interested in this issue...
Comment 10 Aron Budea 2019-09-12 00:31:30 UTC
Happens in Windows as well, see bug 126914, attachment 154112 [details].
Comment 11 Justin L 2019-09-18 05:04:57 UTC
probably a duplicate of 125720
Comment 12 Buovjaga 2019-10-19 08:20:38 UTC

*** This bug has been marked as a duplicate of bug 125720 ***