Download it now!
Bug 126956 - Menus trail off screen (With KDE VCL bug integration)
Summary: Menus trail off screen (With KDE VCL bug integration)
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-08-16 00:14 UTC by cranetester
Modified: 2020-07-12 03:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cranetester 2019-08-16 00:14:48 UTC
Description:
Menus trail off screen. Example: popover on the right is on the screen edge and runs off screen when window is tiled right or maximized.

I am not sure if the bug exists with the GTK theme - I am using the QT theme.

Version: 6.2.5.2
Build ID: 1:6.2.5-0ubuntu0.19.04.1
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US

Steps to Reproduce:
1.Open LO
2. Maximize
3. Click on the popover button in sidebar.

Actual Results:
Menu trails off - not usable.

Expected Results:
Menu should remain inside the window (I think this is the only solution on Wayland anyhow).


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-12-12 13:58:07 UTC
Can you update your libreoffice to 6.3.4 and retest your problem?
Comment 2 Michael Weghorn 2019-12-13 08:25:08 UTC
(In reply to Roman Kuznetsov from comment #1)
> Can you update your libreoffice to 6.3.4 and retest your problem?

And if it still happesn, can you attach a screenshot?

To test whether it also happens with the gtk3 integration, can you start LibreOffice with the corresponding environment variable set (replace "<PATH_TO> with the actual path in this command):

SAL_USE_VCLPLUGIN=gtk3 <PATH_TO>/soffice
Comment 3 QA Administrators 2020-06-11 03:53:50 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2020-07-12 03:37:59 UTC
Dear cranetester,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp