Bug 126992 - FILESAVE: asks to save changes even though NO changes where made in Calc sheet linked to external data
Summary: FILESAVE: asks to save changes even though NO changes where made in Calc shee...
Status: RESOLVED DUPLICATE of bug 122655
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-17 17:20 UTC by Hayo Baan
Modified: 2019-09-26 12:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example (12.76 KB, application/zip)
2019-08-19 12:57 UTC, Hayo Baan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hayo Baan 2019-08-17 17:20:11 UTC
If I open Calc spreadsheet and then close it (after making NO edits), I am asked to save it despite having made no changes.

This does not happen with all spreadsheets, so I guess it has to do with this one containing links to an external document.
Comment 1 Alex Thurgood 2019-08-19 08:57:29 UTC
@Hayo : without a sample set of documents to test, it might be difficult to reproduce this particular case.

Setting NEEDINFO
Comment 2 Alex Thurgood 2019-08-19 09:05:30 UTC
Sounds similar to bug 122655

@Hayo : is the automatic update of links deactivated ?
Comment 3 Hayo Baan 2019-08-19 12:57:10 UTC
Created attachment 153507 [details]
Example

I've attached a zip with two documents to illustrate the issue.

DocSource.ods is a spreadsheet with some data referred to in DocTarget.ods

If in DocTarget.ods you either update the links manually or automatically (e.g. if you have the path in your macro security trusted paths), the document is marked as changed even though nothing was changed.

This used to work correctly in previous versions of LibreOffice.

Hope this can be fixed easily since it breaks my workflow.
Comment 4 Alex Thurgood 2019-08-19 15:14:08 UTC
Thinking that this is a DUP of bug 122655
Comment 5 Xisco Faulí 2019-09-26 12:07:09 UTC

*** This bug has been marked as a duplicate of bug 122655 ***