Bug 127006 - Inserting a Section - Using 'Enter' Key Blows up the Insert Section Function
Summary: Inserting a Section - Using 'Enter' Key Blows up the Insert Section Function
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2019-08-18 12:40 UTC by larrybradley
Modified: 2020-08-11 11:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description larrybradley 2019-08-18 12:40:44 UTC
Description:
When inserting a section, using the Enter used to work the same as clicking on the "Insert" button; now using the Enter key just sort of blows the whole thing up and takes you to the end of the document without inserting the section. It is annoying more than anything else, when you develop a habit of using one method and suddenly it not only does not work, it forces you to re-do your work.

Steps to Reproduce:
1.Insert Section.
2. Type Section name.
3.Hit the enter key.

Actual Results:
Hitting the enter key used to create the section. Now, not only does it not create the section, it takes you to directly to the end of the document, then you must go back and re-create the section and click the "Insert" button instead.

Expected Results:
When I use the Enter key in place of clicking the "insert" key, I expect the section to be created, just like in previous versions of Writer.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Oliver Brinzing 2019-08-19 11:53:25 UTC
I can't reproduce it in

Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: 

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 larrybradley 2019-08-19 16:33:49 UTC
Tried Oliver Brinzing suggestion to change profile in Safe Mode and test again, now when I use the Enter key it completely shuts down Writer and exits LibreOffice completely.
Comment 3 QA Administrators 2019-09-02 09:39:04 UTC Comment hidden (obsolete)
Comment 4 Dieter 2019-09-04 06:23:07 UTC
I can't confirm this with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 01837a85004a6f891a09c0a63ed7eff75d634827
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_00:07:05
Locale: en-GB (de_DE); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-10-16 12:14:31 UTC
Hello larrybradley,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 larrybradley 2019-10-16 15:14:46 UTC
Problem persists in 6.3.2.2
Comment 7 Dieter 2020-01-12 16:13:21 UTC
(In reply to larrybradley from comment #2)
> Tried Oliver Brinzing suggestion to change profile in Safe Mode and test
> again, now when I use the Enter key it completely shuts down Writer and
> exits LibreOffice completely.

So it seems, that a corrupted user profile is the reason for the strange behaviour. Please reset your Libreoffice profile (https://wiki.documentfoundation.org/UserProfile) and re-test. Does this solve your problem?

=> NEEDINFO
Comment 8 QA Administrators 2020-07-11 03:41:47 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2020-08-11 04:07:46 UTC Comment hidden (obsolete)
Comment 10 larrybradley 2020-08-11 11:23:36 UTC
This bug disappeared when I installed a newer version of LO. Never did have to do reset my user profile as you suggested, but maybe installing a newer version took care of that for me? At any rate, no longer experience the issue. Thank you for your help, time and patience. I am changing Status to FIXED.