Bug 127020 - Fonts are blurry on MacOS Retina displays
Summary: Fonts are blurry on MacOS Retina displays
Status: RESOLVED DUPLICATE of bug 122218
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.3.0.3 rc
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-19 09:17 UTC by Jens
Modified: 2020-05-14 10:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens 2019-08-19 09:17:24 UTC
Description:
With the new release candidate of 6.3, the fonts inside documents (at least writer and calc) are blurry, i.e. do not use the high resolution of the display and instead interpolate over 4x4 pixels (I think).
The fonts used for the UI do not have this issue (i.e. menus, icons, UI tooltips etc).
This makes text inside Libreoffice doucments on MacOS very hard to read.

Steps to Reproduce:
1. Start Libreoffice on MacOS
2. Open or create any document
3. Watch blurry fonts (any font)

Actual Results:
Fonts blurry

Expected Results:
Fonts should be crisp and use the HiDPI (Retina) display.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no

OpenGL setting is not relevant (both settings cause blurryness)
Comment 1 Alex Thurgood 2019-08-19 09:31:36 UTC

*** This bug has been marked as a duplicate of bug 122218 ***
Comment 2 Daniel Fyles 2020-02-23 21:17:44 UTC
As of LibreOffice 6.3.4.2 this bug is back, exactly as described previously.

Which is to say that most of the UI is the correct resolution, but all of the document and some UI elements are "blurred".

This is running on an iMac Retina 5K, 27inch, Late 2015
MacOS Catalina 10.15.3

I'd be more than happy to provide any further details required.
Comment 3 Nick 2020-02-24 05:50:30 UTC
A fix is described here: https://bugs.documentfoundation.org/show_bug.cgi?id=122218#c181

Thanks
Comment 4 V Stuart Foote 2020-04-24 16:15:01 UTC

*** This bug has been marked as a duplicate of bug 122218 ***