Download it now!
Bug 127026 - SVG import to Writer: Line Thickness displayed incorrect depending on Zoom-level
Summary: SVG import to Writer: Line Thickness displayed incorrect depending on Zoom-level
Status: RESOLVED DUPLICATE of bug 124848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: SVG-Import Zoom-Issues
  Show dependency treegraph
 
Reported: 2019-08-19 12:49 UTC by Christoph Bartz
Modified: 2019-09-18 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample for bug 127026 (63.11 KB, application/vnd.oasis.opendocument.text)
2019-08-27 08:59 UTC, Christoph Bartz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Bartz 2019-08-19 12:49:15 UTC
Description:
When importing a SVG File into a Writer document, the SVG file is shown as a figure in the document.
But in that figure all Lines with thin width (e.g. 0,5pt) displayed incorrect: 
They are displayed much thicker than they should. 

But it is just a bug in displaying. When exporting to PDF or Print, the lines are displayed/printed correctly. So, it is just a Viewing Bug, no problem with the document itself.

BTW: It doesnt matter if OpenGL is enabled or not.

This bug occured after Updating LibreOffice from 6.2.1 to 6.2.5.

Steps to Reproduce:
1. Open new document in Writer.
2. Click and drag a SVG File from Explorer into document.
-> Thin Lines in SVG figure are displayed incorrect.
3. Export to PDF.
-> Everything ok.

Actual Results:
Thin Lines are displayed incorrectly. 

Expected Results:
All Lines should be displayed exactly the way they are defined.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 2; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded 

SVG Files are created by Inkscape.
Comment 1 Christoph Bartz 2019-08-19 13:30:20 UTC
UPDATE:
I realized that it is a Zooming Issue: 
When Zooming in:  it is ok.
When Zooming out: problem occurs.
Comment 2 Xisco Faulí 2019-08-20 13:44:21 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 3 Christoph Bartz 2019-08-27 08:59:22 UTC
Created attachment 153683 [details]
Sample for bug 127026

A sample ODT Document, showing a figure in 3 different ways:
1. in original SVG Format; 
2. how it looks on my screen (screenshot); 
3. how it should look like (PNG Format).
Comment 4 Dieter 2019-09-02 05:07:45 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 01837a85004a6f891a09c0a63ed7eff75d634827
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_00:07:05
Locale: en-GB (de_DE); UI-Language: en-US
Calc: threaded

100%: 0,5pt and 0,1pt are to thick
110%: 0,5pt is O. K., but 0,1pt still to thick
550%: 0,1pt is O. K.
Comment 5 Xisco Faulí 2019-09-18 11:03:53 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9fa01a8d1137a95af9865a3e47995734c40da6e, which is the same as in bug 124848.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 124848 ***