Bug 127028 - Add DRAW templates to LibreOffice
Summary: Add DRAW templates to LibreOffice
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.0.2 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.5
Keywords: needsUXEval, topicDesign
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2019-08-19 13:36 UTC by Olivier Hallot
Modified: 2021-06-18 11:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2019-08-19 13:36:03 UTC
The menu Page -> Master Page uses Impress master slide selector for drawings which is not so useful.

There are no DRAW templates in the standard packages of LibreOffice.

A minimal set of templates will help to a better usage of DRAW.

Suggestions:
- Technical drawings templates (with frames indicating drawing number, version, author, revisor, date of publishing, etc...) 
- Greetings cards
- Labels
Comment 1 andreas_k 2019-08-19 13:41:05 UTC
Template examples:
- perfect fit with writer template, so if you export the writer or draw document to pdf it look similar.
- perfect fit with impress template, so if you export your presentation from draw it will look the same than in impress.
Comment 2 andreas_k 2019-08-19 13:42:19 UTC
templates for specific topics like we can show how gallery items will work.
- flowchart,
- bpmn, 
- uml,
- ...
Comment 3 Heiko Tietze 2021-05-25 09:51:50 UTC
Andreas, since you added BPMN should we resolve this ticket as fixed or add more templates?
Comment 4 andreas_k 2021-05-25 10:26:37 UTC
fixed.
Comment 5 Heiko Tietze 2021-05-25 10:40:50 UTC
FTR: https://gerrit.libreoffice.org/c/core/+/93514
Comment 6 BogdanB 2021-06-01 09:06:21 UTC
If I open File - Templates - Drawing

OR

File - Templates - Draw Templates 

we have NO templates. In Writer templates there is "bpmn" and is opening with Draw, but it is in the wrong category, Writer and NO in Draw. Could this be solved here, not to open a new bug? And after that I will mark this as verified.

Tested with
Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: f49e5902a3737c02fabf5bec23243ccb126426c4
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 7 BogdanB 2021-06-06 13:42:00 UTC
Please read comment 6, should I mark this as Verified, or things can be improved before?
Comment 8 Tomaz Vajngerl 2021-06-07 07:55:31 UTC
So the issue is only that the bpmn file has the extension ott instead of otg
Comment 9 Tomaz Vajngerl 2021-06-07 08:13:02 UTC
Hope this solves the issue: https://gerrit.libreoffice.org/c/core/+/116775
Comment 10 Commit Notification 2021-06-07 10:25:53 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e9a824dd6c1c33777461874d9892343d193c867d

tdf#127028 "bpmn" template should have ext. otg instead of ott

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 BogdanB 2021-06-10 17:53:56 UTC
Thanks Tomas for this fix. Everything is now perfect. We have now the first template for Draw.
Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 68b6004fe9df184bcbaf46dd53abfec228219df6
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 12 Commit Notification 2021-06-18 11:09:09 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/9799f798d8f84f352aa46e4e923e05e74c68f586

tdf#127028 "bpmn" template should have ext. otg instead of ott

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.