Download it now!
Bug 127051 - FILESAVE: XLSX: Large White Square objects several levels deep appear in the upper left corner of some sheets in the workbook
Summary: FILESAVE: XLSX: Large White Square objects several levels deep appear in the ...
Status: RESOLVED DUPLICATE of bug 117274
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2019-08-20 12:05 UTC by tom1williams
Modified: 2020-02-06 14:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
this workbook has the bug described (916.96 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-08-20 12:11 UTC, tom1williams
Details
this is the same file but never opened, edited and saved by LO CALC 6.2.6.2 (181.51 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-08-21 07:00 UTC, tom1williams
Details
Minimized XLSX based on original (10.46 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-09-15 23:05 UTC, Aron Budea
Details
Multiple white square over data (158.22 KB, image/jpeg)
2019-10-28 07:26 UTC, Paolo Provesi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tom1williams 2019-08-20 12:05:21 UTC
Description:
At FILEOPEN Large White Square objects several levels deep appear in the upper left corner of some sheets of the workbook. I have to click on them and hit delete to remove them. Below one square is yet another square that needs deleting too. After many deletes my data appears and is unharmed.

This has happened in other workbooks my employer uses also, but this is the first workbook where the data was not confidential so that I could send it to you in a bug report.

All other company employees are using MS Office 365 or some other version of MS Office so I must always use .XLSX format.

Steps to Reproduce:
1.Open this attached workbook
2.The first two sheets are okay but the "Total Sales by Region", "Ethernet" and "Fibre Channel" tabs all have big white objects covering my data. 
3. The white square objects have to be deleted one by one repeatedly until my data appears. 

Actual Results:
See steps 2 and 3 above

Expected Results:
The file should have only had my data on each sheet! Nobody put the big white objects there. It is a problem in the SAVEFILE or OPENFILE process I think.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.6.2
Build ID: 1:6.2.6-0ubuntu0.19.04.1
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

glxinfo | grep OpenGL
vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.0.8
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 19.0.8
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 19.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
Comment 1 tom1williams 2019-08-20 12:11:25 UTC
Created attachment 153531 [details]
this workbook has the bug described
Comment 2 Xisco Faulí 2019-08-20 13:20:18 UTC
Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 686b3b5bfc8caac0d5db7c9845fafd32250281e2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

and

LibreOffice 3.5.0 
Build ID: d6cde02
Comment 3 Xisco Faulí 2019-08-20 13:21:56 UTC
Wait a second, the large white squares are also present in MSO Excel 2010. The file is not even compatible among the different versions of MSO.
Closing as RESOLVED NOTABUG
Comment 4 tom1williams 2019-08-21 06:42:14 UTC
If I take the file emailed to me by my MSO using colleagues while it is still in my Thunderbird Inbox and never opened by LO CALC but only open with MSO it does not have these big white square objects. After I have opened it in LO CALC the objects are there and they stay there even when emailed back to colleagues using MSO. So it is a bug, and for us it is a devastating bug. I mean my company will forbid me to keep on using LO which is very bad for me. The white objects are many levels deep and it is very hard to remove all of them. Please re-open this bug. Thank you!
Comment 5 tom1williams 2019-08-21 07:00:48 UTC
Created attachment 153542 [details]
this is the same file but never opened, edited and saved by LO CALC 6.2.6.2

Attached is the same file but never opened, edited and saved by LO CALC 6.2.6.2

I do not know if the big white unwanted objects are introduced by the LO FILEOPEN or by my repeated LO FILESAVE operations during/after editing. Due to the fact that the objects are many levels deep and I do a file save after every so many edits it may be the FILESAVE not the FILEOPEN where the bug occurs. Seriously Thank You for your help on this!
Comment 6 Xisco Faulí 2019-08-21 11:11:40 UTC
(In reply to tom1williams from comment #4)
> If I take the file emailed to me by my MSO using colleagues while it is
> still in my Thunderbird Inbox and never opened by LO CALC but only open with
> MSO it does not have these big white square objects. After I have opened it
> in LO CALC the objects are there and they stay there even when emailed back
> to colleagues using MSO. So it is a bug, and for us it is a devastating bug.
> I mean my company will forbid me to keep on using LO which is very bad for
> me. The white objects are many levels deep and it is very hard to remove all
> of them. Please re-open this bug. Thank you!

What version of MSO are you using?
The problem is you're using a document that is not even compatible among the different versions of MSO
Comment 7 tom1williams 2019-08-23 05:12:07 UTC
This document has been around for many years and gets updated twice per year by multiple people. Most of the company now uses MSO 365 which updates itself automatically. It is safe to assume that at some time in its lifespan this document was edited by MSO 2010, 2015, 2016 and 365 on both Mac and Windows. 

But the main point is my LO 6.2.6.2 put in these empty frames and once they were in the document they stay in the document no matter what software opens it. I am guessing that when I edit certain sheets and hit FILESAVE it puts in an empty frame. If I saved 5 times after different edits on a given sheet there may be 5 empty frames on top of one another on that sheet the next time the document is opened. At least that is my best guess as to what might be happening. Thank you for your help!!
Comment 8 Aron Budea 2019-08-25 03:38:56 UTC
Seems like this is a case similar to bug 108691.
These aren't really frames, but large white shapes that are set to hidden in Excel. For some reason the visibility setting isn't saved properly, that's why they end up being visible upon subsequent load.
Comment 9 Aron Budea 2019-09-15 23:05:55 UTC
Created attachment 154184 [details]
Minimized XLSX based on original

I removed the stuff not needed for reproducing this bug, and created a smaller XLSX.
Comment 10 Paolo Provesi 2019-10-28 07:26:39 UTC
Created attachment 155356 [details]
Multiple white square over data
Comment 11 Paolo Provesi 2019-10-29 17:51:45 UTC
I have the same problem like tom1williams. The problem born opening files with excel 2013 after modification with CALC (files previously created with MS office 2013).
Tried with older version (the last 5.xxx) and there is no problem. I'm still using 5.4.xxxx edition on 2 pc (32 and 64 bit) without problem.

Problem is born with 6.xxx edition
Comment 12 Paolo Provesi 2019-10-31 14:10:42 UTC
(In reply to Aron Budea from comment #9)
> Created attachment 154184 [details]
> Minimized XLSX based on original
> 
> I removed the stuff not needed for reproducing this bug, and created a
> smaller XLSX.

For me, in my PC, your file is correct; no white squares are presents
Comment 13 NISZ LibreOffice Team 2020-02-06 14:45:50 UTC

*** This bug has been marked as a duplicate of bug 117274 ***