Download it now!
Bug 127052 - FILEOPEN: DOCX: Image in header is shown twice after import, cannot type in header or body
Summary: FILEOPEN: DOCX: Image in header is shown twice after import, cannot type in h...
Status: RESOLVED DUPLICATE of bug 130167
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2019-08-20 12:50 UTC by Olaf Felka
Modified: 2020-02-10 16:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bug docx (4.41 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-08-20 12:51 UTC, Olaf Felka
Details
comparison MSO 2010 and LibreOffice 6.4 Master (66.57 KB, image/png)
2019-08-20 13:06 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Felka 2019-08-20 12:50:25 UTC
Description:
The image in the header of a docx file is shown twice

Steps to Reproduce:
1. open attached file in LO 6.3.0.4
2. Compare to MS Office

Actual Results:
LO shows the image in header twice

Expected Results:
LO shows the image in header once


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 16; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 1 Olaf Felka 2019-08-20 12:51:13 UTC
Created attachment 153533 [details]
bug docx
Comment 2 Xisco Faulí 2019-08-20 13:06:41 UTC
Created attachment 153534 [details]
comparison MSO 2010 and LibreOffice 6.4 Master
Comment 3 Xisco Faulí 2019-08-20 13:07:49 UTC
Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 686b3b5bfc8caac0d5db7c9845fafd32250281e2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-08-20 13:10:50 UTC
Also reproduced in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

but not in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 5 Timur 2020-01-06 19:30:13 UTC
It's not just image issue, but we cannot type in document body or header. Still in 6.5+.
And typing wasn't OK also in 4.2.
If document resaved in MSO, we can type in body but not in header.
Comment 6 Aron Budea 2020-02-01 21:22:04 UTC
There are three starting point for the two issues.

1. Text can't be entered anymore.
This started with the following commit, bibisected using repo bibisect-42max. Same commit as for bug 130167.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=782adba4d436c65cdf85d48f28486321873b15ed
author		Adam Co <rattles2013@gmail.com>	2013-06-12 15:06:42 +0300
committer	Miklos Vajna <vmiklos@suse.cz>	2013-06-19 14:31:38 +0200

"fdo#64238: fix for missing footer bug"

2. Duplicated image in the header
a. Two separate images
This can be seen in 4.2.0.4, but the bibisect repo in Linux has a range where opening this document crashes LO (end of bibisect-42max, beginning of bibisect-43max). It could be bibisected with bibisect-win32-4.3 to the following commit.

Not sure if the result is correct, but the commit has been backported to libreoffice-4-2. On the other hand, there was no similar bug in the build with the commit preceding 3998d1abb291 (the commit that was partially reverted here).

https://cgit.freedesktop.org/libreoffice/core/commit/?id=70068f428d570a4ee00c682f1b8e12de395a8be4
author		Andras Timar <andras.timar@collabora.com>	2014-01-19 19:13:57 +0100
committer	Andras Timar <andras.timar@collabora.com>	2014-01-19 19:13:57 +0100

"fdo#73764 partially revert 3998d1abb291"

b. Single image with shadow
This started with the following commit, bibisected using repo bibisect-linux-64-6.0.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ada232a67fbb3acf60b104a4916719dbdb891819
author		Patrick Jaap <patrick.jaap@tu-dresden.de>	2018-01-15 16:43:07 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-01-23 23:28:04 +0100

"tdf#113946 add 'topMargin' to GraphicHelpers import"
Comment 7 Timur 2020-02-07 10:47:41 UTC
Thanks Aron for triple bibisect.
As recently, since Adam Co is not active, I'll be free to add here Miklos, who is committer and Justin, who does a lot of similar issues.
We can open separately for other issues.
Comment 8 Justin L 2020-02-10 15:51:08 UTC
(In reply to Aron Budea from comment #6)
> 2. Duplicated image in the header
This one should be fixed for LO 7.0 from bug 130167 - which referenced this bug.
Comment 9 Justin L 2020-02-10 16:23:27 UTC
(In reply to Aron Budea from comment #6)
> 2. Duplicated image in the header
> b. Single image with shadow
I wasn't clear on what this was indicating so I did the bibisect myself. (Ultimately, this was LibreOffice 6.1 backported to 6.0.). It is just referring to the fact that the duplicated image changed position to be just slightly offset underneath the other image, creating a shadow effect. But really it is just one image in the header and the other image in the text body overlapping.

So this is the same problem, and the same fix as was mentioned in comment 8.
Comment 10 Justin L 2020-02-10 16:35:31 UTC
(In reply to Aron Budea from comment #6)
> 1. Text can't be entered anymore.
If you look carefully, you will notice some "box-handles" around the page frame. Several full-page images were loaded as part of the unused headers.  That's why you can't enter text - because you have an image selected.  Deleting the three image allows easy access to the header/body again. So once again, the same problem and the same fix.

*** This bug has been marked as a duplicate of bug 130167 ***