Bug 127060 - LibreOffice stops responding during spell check after pressing IgnoreAll
Summary: LibreOffice stops responding during spell check after pressing IgnoreAll
Status: RESOLVED DUPLICATE of bug 128074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
: 126843 127697 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-20 17:20 UTC by Arthur
Modified: 2019-10-16 14:58 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (29.56 KB, application/vnd.oasis.opendocument.text)
2019-08-21 11:41 UTC, Xisco Faulí
Details
Sample 2 (12.35 KB, application/vnd.oasis.opendocument.text)
2019-10-03 12:39 UTC, Xisco Faulí
Details
Flamegraph (117.36 KB, application/x-bzip)
2019-10-03 20:02 UTC, Julien Nabet
Details
easily reproducalbe file (8.73 KB, application/vnd.oasis.opendocument.text)
2019-10-04 09:34 UTC, karl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arthur 2019-08-20 17:20:16 UTC
Description:
During a spell check, LibreOffice stops responding after pressing [IgnoreAll]

Previous versions of LibreOffice have not displayed this behavior.  I have written 13 previous books with this software, and this is thre first time it has stopped responding during a spell check.  It was necessary to"Close the program" after ending the program in Task Manager.

LibreOffice provided the following information

Description:
  A problem caused this program to stop interacting with Windows.

Problem signature:
  Problem Event Name:	AppHangB1
  Application Name:	soffice.bin
  Application Version:	6.3.0.4
  Application Timestamp:	5d49eb81
  Hang Signature:	9928
  Hang Type:	0
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1033
  Additional Hang Signature 1:	99282a8744996aac6ed2a782a4ede51c
  Additional Hang Signature 2:	a75a
  Additional Hang Signature 3:	a75a6e88ac3042bbfb1fcbf41e3ede9a
  Additional Hang Signature 4:	9928
  Additional Hang Signature 5:	99282a8744996aac6ed2a782a4ede51c
  Additional Hang Signature 6:	a75a
  Additional Hang Signature 7:	a75a6e88ac3042bbfb1fcbf41e3ede9a

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt


Steps to Reproduce:
1. Use spell check on a reasonably large document
2. Select [IgnoreAll] to ignore words that are Klingon names 
3. Sooner or later program will stop responding

Actual Results:
Program stops responding to Windows.

Expected Results:
The program ideally would not stop responding to Windows, and should continue the spell check.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: StartModule
[Information guessed from browser]
OS: Windows (All)
OS iVersion: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threadeds 64bit: no
Comment 1 IM 2019-08-20 22:18:48 UTC
Thank you for reporting the bug. I can confirm that the bug is present in:

Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded

It takes tens of Ignore ALL clicks to make Writer stop response.
Comment 2 Julien Nabet 2019-08-21 10:08:56 UTC
On Win10 with master sources updated today, I don't reproduce this but noticed these logs during tests:
warn:legacy.osl:11696:30980:sw/source/uibase/dialog/SwSpellDialogChildWindow.cxx:434: ApplyChangedSentence in initial call or after resume
warn:legacy.tools:11696:30980:linguistic/source/gciterator.cxx:777: nSuggestedEndOfSentencePos calculation failed?
warn:linguistic:11696:30980:linguistic/source/gciterator.cxx:815: end-of-sentence detection failed?

warn:svl:11696:30980:svl/source/undo/undo.cxx:445: SfxUndoManager::Clear: suspicious call - do you really wish to clear the current level?
warn:svl:11696:30980:svl/source/undo/undo.cxx:445: SfxUndoManager::Clear: suspicious call - do you really wish to clear the current level?
warn:svl:11696:30980:svl/source/undo/undo.cxx:445: SfxUndoManager::Clear: suspicious call - do you really wish to clear the current level?
warn:svl:11696:30980:svl/source/undo/undo.cxx:445: SfxUndoManager::Clear: suspicious call - do you really wish to clear the current level?
warn:svl:11696:30980:svl/source/undo/undo.cxx:445: SfxUndoManager::Clear: suspicious call - do you really wish to clear the current level?
Comment 3 Xisco Faulí 2019-08-21 11:41:33 UTC
Also reproducible in

Version: 6.4.0.0.alpha0+
Build ID: 2bed8af91fc2654b9ed2432f969d32d5741a529b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-08-21 11:41:57 UTC
Created attachment 153552 [details]
sample file
Comment 5 Xisco Faulí 2019-08-21 11:55:04 UTC
Hi Arthur,
Which version of LibreOffice were you using before?

I can also reproduce it in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

with my file attached. it seems like a performance issue...

@Julien Nabet, can you reproduce it with my file ?
Comment 6 Arthur 2019-08-21 15:06:48 UTC
In LibreOffice_6.2.5_Win_x64 I did not encounter the issue where it stops responding.  I have had issues with spell check before, but never where it causes the program to stop responding.
Comment 7 Julien Nabet 2019-08-21 15:21:05 UTC
(In reply to Xisco Faulí from comment #5)
> ...
> @Julien Nabet, can you reproduce it with my file ?

On Win10 with LO 6.3.0, I don't reproduce this.
I tested 2 ways with your file:
1) right click on a word with red spelling line, "Ignore all", nothing special
2) F7, click button "Ignore all", click "Close" button, nothing too.

I'll give a try on my Linux machine.
Comment 8 Arthur 2019-08-21 15:41:37 UTC
 I used the spelling dialog which is brought up by pressing F7.
Comment 9 Julien Nabet 2019-08-21 17:57:27 UTC
On pc Debian x86-64 with master sources updated today + gtk3, I don't reproduce this.
(with English US or French UI)
Comment 10 Xisco Faulí 2019-09-02 15:17:39 UTC
*** Bug 126843 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2019-09-30 13:47:14 UTC
*** Bug 127697 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2019-09-30 13:48:00 UTC
Increasing severity as we have already 2 duplicates
Comment 13 Xisco Faulí 2019-10-03 09:48:49 UTC
(In reply to Julien Nabet from comment #7)
> (In reply to Xisco Faulí from comment #5)
> > ...
> > @Julien Nabet, can you reproduce it with my file ?
> 
> On Win10 with LO 6.3.0, I don't reproduce this.
> I tested 2 ways with your file:
> 1) right click on a word with red spelling line, "Ignore all", nothing
> special
> 2) F7, click button "Ignore all", click "Close" button, nothing too.
> 
> I'll give a try on my Linux machine.

Hi Julien,
Just for the record,
Once I open the document attached, I need to click on 'Ignore all' many times until it hangs, 20 to 30 times...
Comment 14 Xisco Faulí 2019-10-03 10:23:10 UTC
Regression introduced by

https://cgit.freedesktop.org/libreoffice/core/commit/?id=86f876b45a2737a1f7ccf9581af05277e1650159

author	Andras Timar <andras.timar@collabora.com>	2014-11-03 12:03:48 +0100
committer	Andras Timar <andras.timar@collabora.com>	2014-11-03 12:10:33 +0100
commit	86f876b45a2737a1f7ccf9581af05277e1650159 (patch)
tree	32b054567dbc4e20bdc2575a71f7248a1c1b286d
parent	4e87e0f2da6bc132edc42056db1d91e63e9497e7 (diff)
fdo#61167 suggest titlecase and uppercase words from exception dict

Bisected with: bibisect-44max

Adding Cc: to Andras Timar
Comment 15 Julien Nabet 2019-10-03 12:19:00 UTC
(In reply to Xisco Faulí from comment #13)
> 
> Just for the record,
> Once I open the document attached, I need to click on 'Ignore all' many
> times until it hangs, 20 to 30 times...

With English UI, I typed more than 30 words, each time:
- type a word + Enter (so there's the spell check)
- right click ignore all
=> no hanging
(Win10 version 1709 with master sources updated today)
Comment 16 Xisco Faulí 2019-10-03 12:37:59 UTC
I've just tried in

Versión: 6.3.1.2 (x86)
Id. de compilación: b79626edf0065ac373bd1df5c28bd630b4424273
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

so I reproduced the hang 1 time out of 5 tries
Comment 17 Xisco Faulí 2019-10-03 12:39:06 UTC
Created attachment 154732 [details]
Sample 2

However, this file hangs systematically for me when the word 'magna' is spellchecked in

Versión: 6.3.1.2 (x86)
Id. de compilación: b79626edf0065ac373bd1df5c28bd630b4424273
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

but not on linux.

@Julien, could you please give a try with this file ?
Comment 18 Julien Nabet 2019-10-03 13:40:18 UTC
(In reply to Xisco Faulí from comment #17)
> ...
> @Julien, could you please give a try with this file ?

I selected every redlined word of the 2 first sentences, did a right click + ignore all of each of them, no hanging.
(still on Win10 version 1709, with master sources updated today).
Comment 19 bchemnet 2019-10-03 13:51:57 UTC
To clarify the nature of the bug as I first reported it (although that was designated a duplicate after this bug was reported): the issue as I experience it occurs in the Spell Check Dialog when pressing the Ignore All button.  The right-click ignore all does not consistently exhibit the behavior (i.e., Ignore All in the dialog menu does not cause the same problem).

I only realized there was a difference in behavior from reading these comments because I normally disable spell check as I type.

So for those who are reporting no issue, could you try again with the spell check dialog instead of the right click menu?
Comment 20 Julien Nabet 2019-10-03 14:05:35 UTC
(In reply to bchemnet from comment #19)
> ...
> So for those who are reporting no issue, could you try again with the spell
> check dialog instead of the right click menu?

Here are the actions I did with Xisco's file:
- opened it
- select Tools/Spelling...
=> dialog Spelling appears
- click "ignore all" buttons several times.
Sometimes LO takes some seconds before you can go on but no hanging.
These seconds may reveal a real problem here since it's just some lines on a file.
I imagine it could be far worse on a file corresponding to a book.

(I tested this with all the selection considered as English and also considered as French (France) to compare.)

Xisco: I'll provide a Flamegraph, perhaps it may be useful.
Comment 21 Julien Nabet 2019-10-03 18:38:18 UTC
I won't be able to provide a Flamegraph for the moment because of this build error:
/home/julien/lo/libo_perf/vcl/unx/gtk3_kde5/a11y/gtk3_kde5_atkwindow.cxx:10:10: fatal error: ../../gtk3/a11y/gtk3atkwindow.cxx: Aucun fichier ou dossier de ce type
   10 | #include "../../gtk3/a11y/gtk3atkwindow.cxx"
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.

I already emailed Noel since it's related to https://cgit.freedesktop.org/libreoffice/core/commit/?id=09f77e8ed51fc64fccc6a14e87eed48b2f15a28d
Comment 22 Julien Nabet 2019-10-03 20:02:43 UTC
Created attachment 154740 [details]
Flamegraph

I could finally build master sources updated today by applying https://cgit.freedesktop.org/libreoffice/core/commit/?id=34095197fcb992d3c1ea63888918495fcc6f6994

I started Flamegraph just after having called spell dialog box.
I closed it once I clicked enough times "Ignore all" so there's no more words redlined.
Comment 23 karl 2019-10-04 09:33:53 UTC
I have a very easy and reproduceable sample (just 3 words in writer, no big document). 

Steps: 
1) Open File sample 3
2) start spell checker (german version in my case)
3) click "ignore all" for the word "climate"

Version: 6.3.1.2 (x64)
Build-ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-AT (de_AT); UI-Sprache: de-DE
Calc: threaded
Comment 24 karl 2019-10-04 09:34:54 UTC
Created attachment 154757 [details]
easily reproducalbe file
Comment 25 Fred 2019-10-05 11:22:48 UTC
Same bug here (debian stable, LO from bakports repo) with the last backported version of LO : 

Version: 6.3.2.2
Build ID: 1:6.3.2-1~bpo10+1
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: gtk2; 
Locale: fr-BE (en_US.utf8); UI-Language: en-US
Calc: threaded

Create an empty doc with the words "Le frwt va frwt bien frwt oui.", ignore all will freeze LO eather for english or french spellchecking.

I have also some problems with french spellchecking (extension grammalecte, last version, 1.5.0, but former ones are also buging) on a long text (350 p.), it will freeze easily on "correct", I must "ignore" and correcting directly in the text.
Comment 26 Xisco Faulí 2019-10-16 14:58:53 UTC
So it seems my bisection and the original report are different issues.
Since 6.3, we have got more reports about 'Ignore all', which is reported in bug 128074.
Closing as duplicated. I'll report my bisection in another bug...

*** This bug has been marked as a duplicate of bug 128074 ***