Bug 127078 - DOC: Input fields modified before printing
Summary: DOC: Input fields modified before printing
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: regression
Depends on:
Blocks: Fields-Cross-Reference Bookmarks
  Show dependency treegraph
Reported: 2019-08-21 10:08 UTC by luca.manganelli
Modified: 2024-02-24 01:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

odt file for the bug (10.70 KB, application/vnd.oasis.opendocument.text)
2019-08-21 10:08 UTC, luca.manganelli
new DOC with the bug (24.00 KB, application/msword)
2019-09-17 10:08 UTC, luca.manganelli
Video demonstrating the bug (2.21 MB, video/webm)
2019-09-17 10:09 UTC, luca.manganelli

Note You need to log in before you can comment on or make changes to this bug.
Description luca.manganelli 2019-08-21 10:08:04 UTC
Hello, test the attached document. Fill the grey fields.

When I open the print dialog (or, after closing it without printing, I double-click on the first ROAD field), the first ROAD grey field is corrupted and have the TIMETABLE value copied inside its text...

Steps to Reproduce:
1. write on fields
2. open print dialog (if the bug doesn't appear, close the print dialog and double click on first field)

Actual Results:
The first field is corrupted

Expected Results:
The first field should not be modified

Reproducible: Always

User Profile Reset: No

Additional Info:
Comment 1 luca.manganelli 2019-08-21 10:08:36 UTC
Created attachment 153550 [details]
odt file for the bug
Comment 2 Durgapriyanka 2019-09-16 16:17:12 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2019-09-17 05:22:11 UTC Comment hidden (obsolete)
Comment 4 luca.manganelli 2019-09-17 10:08:55 UTC
Created attachment 154216 [details]
new DOC with the bug
Comment 5 luca.manganelli 2019-09-17 10:09:34 UTC
Created attachment 154217 [details]
Video demonstrating the bug
Comment 6 luca.manganelli 2019-09-17 10:12:05 UTC
now I've uploaded a new version of the doc and a video about it.
I'm using LibreOffice 6.2.7 (the STILL version).

Steps to reproduce it:

go to the field in which the value is "ewqewqew 2", double click on it and write a new number (in the video I added a 2 to the end -> "ewqewqew 22")

you see that the fields is modified...
Comment 7 Dieter 2019-09-17 10:37:47 UTC
I confirm it with

Version: (x64)
Build-ID: f0c832acb53326ccc9a8c1a47401fbc9e1081feb
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-11_05:46:53
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 8 Dieter 2021-08-13 06:47:32 UTC
Still present in

Version: (x64) / LibreOffice Community
Build ID: ac80ec817eb07c77a51bc0729985a473c734182e
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Steps to reproduce

1. Open attachment 154216 [details]
2. Double click in field of cell B1 in first table (ewqewqew 2)
3. Change entry to ewqewqew 23 => OK

Actual result
entry changes to ewqewqew 210.00 - 12.000.00 - 12.00

Expected result
no change (still ewqewqew 23)
Comment 9 QA Administrators 2023-08-14 03:13:30 UTC Comment hidden (obsolete)
Comment 10 luca.manganelli 2023-08-16 09:24:22 UTC
(In reply to QA Administrators from comment #9)
> Test to see if the bug is still present with the latest version of
> LibreOffice from https://www.libreoffice.org/download/

It is still present in the actually latest LibreOffice 7.5.5.

> 1. Download and install oldest version of LibreOffice (usually 3.3 unless
> your bug pertains to a feature added after 3.3) from
> https://downloadarchive.documentfoundation.org/libreoffice/old/

I downloaded all old version of LibreOffice from 3.3 to earlier, and I discovered that this bug appeared between:

 - LibreOffice 4.2.8 is the LAST working version, WITHOUT this bug
 - LibreOffice is the first next release I tried that HAS this bug

(I have tried many releases, all higher than 4.3, and they have all this bug).
Comment 11 raal 2023-12-28 16:24:33 UTC
No repro with Version: (X86_64) / LibreOffice Community
Build ID: 71c28942fbc7f36e5bcd46c5a6cdfbb3fcbcd6a0
CPU threads: 4; OS: Linux 6.2; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded

Seems to be fixed with dev version. Please could you test it with
dev version?  You can download it here:
Thank you
Comment 12 Dieter 2023-12-28 18:27:40 UTC
Yes, no repro with

Version: (X86_64) / LibreOffice Community
Build ID: 40617d867346956588ac023511f31210107217f4
CPU threads: 4; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL threaded