Download it now!
Bug 127086 - PPT: FILESAVE: Crop image is gone after RT
Summary: PPT: FILESAVE: Crop image is gone after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: high major
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.4 target:7.2....
Keywords: bibisected, bisected, dataLoss, filter:ppt, regression
Depends on:
Blocks: PPT OOXML-support-crop-shape-regressions
  Show dependency treegraph
 
Reported: 2019-08-21 15:23 UTC by Xisco Faulí
Modified: 2020-12-04 12:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-08-21 15:23:18 UTC
Steps to reproduce:
1. Open attachment 56444 [details] from bug 45496
2. Save it as .PPT
3. Open the generated file

-> The image on slide 1 is gone

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 2bed8af91fc2654b9ed2432f969d32d5741a529b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2019-08-21 15:24:07 UTC
Regression introduced by:

author	Tamas Bunth <tamas.bunth@collabora.co.uk>	2019-05-13 01:02:07 +0200
committer	Tamás Bunth <btomi96@gmail.com>	2019-05-13 18:14:26 +0200
commit	f4ba484183a1e7b9824f10580d633466c266828f (patch)
tree	5795d2c442e3dbb3496fcfd5ac6f5bd8ddc39e15
parent	8401a26363bf7cb3c30bf783b3f8978f4b69e4c4 (diff)
ooxml import: supprt cropping to shape

Bisected with:

Adding Cc: to Tamas Bunth
Comment 2 Julien Nabet 2020-01-19 11:15:36 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I confirm that reverting the patch makes the regression disappear.
Let's increase a bit the importance since it's a regression.

Tamas: any thoughts here?
Comment 3 Timur 2020-03-31 10:01:49 UTC Comment hidden (obsolete)
Comment 4 Timur 2020-11-04 11:22:32 UTC
Repro master 7.1+. Gone in LO and MSO for PPT. OK for PPTX.
Comment 5 Xisco Faulí 2020-11-20 09:07:24 UTC Comment hidden (obsolete)
Comment 6 Miklos Vajna 2020-11-20 10:23:01 UTC
(In reply to Xisco Faulí from comment #5)
> Bisected with: bibisect-linux64-6.3

Thanks. :-)
Comment 7 Commit Notification 2020-11-20 12:28:11 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7032be2e9edd82dad2d67f1582aaa57676bda4a1

tdf#127086 PPT export: fix lost bitmap fill for OOXML custom shapes

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-11-20 20:32:02 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/e403d8416ade9aeaf86468a3e1413677026d9dce

tdf#127086 PPT export: fix lost bitmap fill for OOXML custom shapes

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-12-01 16:21:02 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: 79ec66700266a22966d9e308a716be56c9c3a4a7
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 10 Commit Notification 2020-12-02 16:27:51 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0956226ca535a62ab22d8d2502b159037c327f7d

related: tdf#127086: PPT: export custom shapes as Bitmap

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-12-02 19:04:04 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/528f1ddc89020b3640b901ab213bdf699ad22fda

related: tdf#127086: PPT: export custom shapes as Bitmap

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-12-04 12:23:29 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/2d253ef05719144f5e3d5a773caf8f0b5ec0a02c

related: tdf#127086: PPT: export custom shapes as Bitmap

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.