Bug 127089 - LibreOffice 6.3.0 breaks scrolling in spreadsheets on macOS 10.13.6
Summary: LibreOffice 6.3.0 breaks scrolling in spreadsheets on macOS 10.13.6
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-21 20:04 UTC by chdiza
Modified: 2019-09-23 19:01 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chdiza 2019-08-21 20:04:24 UTC
Description:
When I updated from 6.2.5 to 6.3.0, I immediately noticed problems with scrolling in spreadsheets.

(1) Sideways scrolling direction is broken.  Swiping to the right makes the "view" go to the left.  This is not following the macOS system setting for scroll direction, *even though vertical scrolling does obey the system setting*.

In other words, hortizontal scrolling is backwards but vertical scrolling isn't.

(2) All scrolling in a spreadsheet, whether horizontal or vertical, is *very* sluggish and also there is a very noticeable delay between the start of swiping and when LibreOffice actually responds to that swiping.  It's so bad that I had to revert to 6.2.5.

By the way, these are not gigantic spreadsheets with all sorts of complicated stuff in them.  It's just about 60 rows and 30 columns of words and numbers.

Steps to Reproduce:
1. Make sure that in System Preferences on macOS, in the Trackpad (or mouse) pane, make sure that "Scrolling Direction" is NOT set to "natural".
2.  Open a spreadsheet in libreoffice.
3. Swipe down and up.
4. Then swipe right and left.

Actual Results:
For (3), the view goes down and then up, but *very* sluggishly and with a delay.  For (4), the view goes left and then right (backwards, given the macOS system setting), also sluggishly and with a delay.

Expected Results:
First, as regards step (4), the screen should move right and then left.  Libreoffice should not diverge from the macOS system setting for scroll direction, and it certainly horizontal scrolling shouldn't diverge from vertical.

As regards the sluggishness, that should not happen at all no matter which direction I scroll in.


Reproducible: Always


User Profile Reset: No



Additional Info:
This is on macOS 10.13.6.  I haven't yet tested it on 10.14.6.

None of this was a problem with Libreoffice 6.2.5.  The very same spreadsheets behave as expected as soon as I reverted to 6.2.5, and then they behave badly as soon as I re-upgrade to 6.3.0.
Comment 1 Alex Thurgood 2019-08-22 07:53:00 UTC

*** This bug has been marked as a duplicate of bug 126680 ***
Comment 2 chdiza 2019-09-05 18:10:55 UTC
This report was closed in haste.  It reports two separate bugs, and only one of them was the duplicate of 126680.

The other one---the unusably laggy scrollin---is still present in LibreOffice 6.3.1.2.  I am again forced to downgrade to 6.2.5.

If I should open a new report, let me know.
Comment 3 steve 2019-09-23 16:49:10 UTC
Please file a new bug as per the one issue per bug rule.

The horizontal scrolling issue has been fixed indeed.

For the remaining scrolling issue you reported for open document spreadsheet please file a new bug with a good title that matches the bug.

I tried to reproduce but was unable to do so on macbook pro 2017:
Version: 6.3.1.2
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU threads: 8; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

If possible adding a video recorded with your mobile showing screen and touchpad usage may be helpful to better understand what you are seeing and help others verify the problem discussed.
Comment 4 chdiza 2019-09-23 19:01:48 UTC
OK, I'll open a new issue.  But note that your failure to reproduce isn't very telling.  You did it on a different OS, on a machine with 8 threads.