Download it now!
Bug 127112 - Numbering style editor: Leaving Customize tab with a non-default level selected, then returning to it, gives multiple levels selected, and selection behaves erratically
Summary: Numbering style editor: Leaving Customize tab with a non-default level select...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:7.0.0 target:6.4.1 target:6.3.6
Keywords:
: 129660 130457 (view as bug list)
Depends on:
Blocks: Bullet-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2019-08-23 09:35 UTC by Mike Kaganski
Modified: 2020-03-13 09:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-08-23 09:35:39 UTC
1. Open a numbering style edit dialog;
2. Switch to Customize tab;
3. Click at "1-10" in Level list;
4. Switch to Organizer tab;
5. Switch back to Customize tab.

Both "1-10" and "1" are selected.

6. Click at "9"

"1-10" is deselected, *but not "1"*; "9" is now selected along with "1".
Clicking other items gives strange selection combinations.

All mouse-clicking is not accompanied with any function keys pressed.

Tested with Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Dieter 2019-08-23 09:53:55 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

and with

Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Additional informations:
- similar problem in position tab (see bug 125774)
- Step 5 in LO 6.1.6.3: Only "1" is selected
Comment 2 Vladimir Zhirov 2019-10-25 13:31:01 UTC
I confirm it too.

Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 3 sdc.blanco 2019-12-28 13:56:09 UTC
*** Bug 129660 has been marked as a duplicate of this bug. ***
Comment 4 sdc.blanco 2020-01-19 14:53:51 UTC
confirm with 6.5.0.0.alpha

Additional information about systematic (non-erratic) behavior patterns:

1.  (repeat) click on 1-10.   Will toggle between 1-10 and 1.

2.  Start with level 1.  Choose level 1+n  (both 1 and 1+n are selected)  Click again on 1+n -- then only 1+n is selected.  (as long as you choosing a numerically larger level, then you can click again to only select the larger).

3.  If you select level n, and then try to select a level less than n, then click again does not work.

(sometimes double-click seems necessary)

4.  going to 1-10 gives a "workaround" (using steps 1 and 2)
Comment 5 Commit Notification 2020-01-28 21:20:07 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/62821018c01674e75108898c0f5c9ddb3333cc66

tdf#127112 repair "sticky" levels in Customize numbering style dialog

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-01-28 21:24:14 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/dfbf810ce521f1342dc1f13a6815762c2d7359ce

tdf#127112 repair "sticky" levels in Customize numbering style dialog

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-01-28 21:24:29 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/e65aeb1c9fdc84e6b0645bea067cdbe2de28a052

tdf#127112 repair "sticky" levels in Customize numbering style dialog

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-02-21 15:49:16 UTC
*** Bug 130457 has been marked as a duplicate of this bug. ***
Comment 9 Dieter 2020-03-13 09:02:33 UTC
Verified with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: c63148ba139bd6b9ae7a0f9e24e51f29e5370963
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Seth, thanks for fixing it!