Download it now!
Bug 127121 - Enhancement request: rename file field in the toolbar
Summary: Enhancement request: rename file field in the toolbar
Status: RESOLVED DUPLICATE of bug 103694
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: File-Name
  Show dependency treegraph
 
Reported: 2019-08-23 14:12 UTC by espinosa_cz
Modified: 2019-08-24 12:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description espinosa_cz 2019-08-23 14:12:40 UTC
Description:
I would like to have a convenient file rename functionality in LO, similar what Googdle Docs have.

I like how the rename is implemented there, not as a modal dialog but as a toolbar editable box. 

I also like the idea that user can see the file name all the time, not the full path, just the filename. Not everyone puts a good title to their documents, the filename is sometimes the only usable "title".

LO should have show filename/rename file as editable box in the toolbar. This way it can be easily removed/added if user finds it useful or not.

Yes, I am aware you can rename file outside LO, in a file manager. It's a generic way but because of it also most laborious. It requires closing the file; opening file manager; locating the file, which might not be trivial if you have loads of them; then finally the file renaming; then opening the file again. This is a crime against efficiency :) Clicking, clicking, clicking, searching, clicking, ..all unnecessary!


Actual Results:
As described in the description.

Expected Results:
As described in the description.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-08-24 01:57:56 UTC
While 'open' in LibreOffice a document has been filter imported from its ODF archive, an ODF document archive is only reassembled when saved/exported using applicable filters.

An out of sequence "rename" from a toolbar widget would require a full save/export of the open document to a newly named document, closing/disposition of the open document, and opening of the new document.  And while some parts could probably be done in process with reassignment of temp files it would be an effort to make it reliable.

Not worth the dev effort to do this consistently cross platform when the os/DE provided filing handling is suitable to task.

IMHO => WF
Comment 2 m.a.riosv 2019-08-24 12:08:23 UTC
This was discussed in tdf#103694, I know it is not exactly the same but the underlying problem about rename on fly is, while that is not solved, nothing to do.

*** This bug has been marked as a duplicate of bug 103694 ***