Download it now!
Bug 127126 - UI:Redaction Toolbar, "Export Directly as PDF" should either export a redacted pdf with 100% transparency or be renamed to "Preview PDF Export"
Summary: UI:Redaction Toolbar, "Export Directly as PDF" should either export a redacte...
Status: RESOLVED DUPLICATE of bug 126915
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Redaction
  Show dependency treegraph
 
Reported: 2019-08-23 15:59 UTC by Pedro
Modified: 2019-08-23 16:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2019-08-23 15:59:49 UTC
There are multiple complaints in reviews of the Redaction toolbar about having the "Direct to PDF" button exporting documents with 50% transparency on the redaction bars. Namely on Arstchenica review of 6.3 and on Dedoimedo's review.

https://www.dedoimedo.com/computers/libreoffice-6-3-review.html

 "The one thing that baffles me is that default redaction comes at 50% transparency, so you actually need to change that before you blank the text. But then I'm still wondering how effective this really is, because the actual text still exists, and it's only hidden behind a layer of color. All in all, it works, but there should be more magic to it."

Proposals:

1 - Change the "Export Directly as PDF" to export completely redacted documents with the black bars and not 50% transparent bars. In essence what the "Redacted Export (black)" does currently. Change the current "Export Directly as PDF" action to the drop-down button and name it "Export Preview PDF";

2 - Rename the "Export Directly as PDF" to "Export Preview PDF". This is to address Thomas Lendo rationale that naming the button "Preview" and having a different preview action than in Calc or Writer is a problem. 
By naming it "Export Preview PDF" the user knows that they are not exporting a final redacted version (I would also include a tooltip mentioning that this export, the redaction boxes have 50% transparency).
Comment 1 Muhammet Kara 2019-08-23 16:07:45 UTC
What about adding just an "(Unredacted)" to the end of the label?
Comment 2 Aron Budea 2019-08-23 16:51:43 UTC
Seems like a dupe of bug 126915.

*** This bug has been marked as a duplicate of bug 126915 ***