Bug 127156 - Conflicting hotkeys in German LO Writer for menus "Ansicht" and "Tabelle"
Summary: Conflicting hotkeys in German LO Writer for menus "Ansicht" and "Tabelle"
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2019-08-25 19:44 UTC by Markus
Modified: 2019-09-07 08:47 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot_2019-08-25 (63.06 KB, image/png)
2019-08-25 19:44 UTC, Markus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus 2019-08-25 19:44:57 UTC
Created attachment 153647 [details]
Screenshot_2019-08-25

Invoking the table menu via Alt + "t" like in previous LO versions doesn't work any more (I used 6.0 in Linux Mint 19.1 before installing LO update via PPA).
Instead of "t" the letter "a" is underlined - which conflicts with the view menu (German "Ansicht").
The first time you press Alt + "a" it opens the view menu, the second time (after ESC) it opens the table menu, and so on.
Alt + "a" > "a" (like in Windows apps with conflicting hotkeys) doesn't work either.
Very annoying for a feature (working with writer tables) which I use very often!
Seems to be the same in LO 6.2.3.2 / Windows Version - according to https://www.libreoffice-forum.de/viewtopic.php?f=5&t=23258&p=65725#p65725).
Comment 1 Dieter 2019-08-25 20:11:42 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build-ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

and also with

Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

but not with

Version: 6.1.6.3 (x64)
Build-ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group threaded
Comment 3 Julien Nabet 2019-08-27 08:51:19 UTC
(In reply to Julien Nabet from comment #2)
>...
> Should I make the change into 6.2 repo?
> https://translations.documentfoundation.org/de/libo62_ui/translate/
> #search=T~abelle&sfields=source,target

I finally also did the change in 6.2 branch.
If it causes some pb, don't hesitate to revert or to ask me to revert.
Comment 4 Xisco Faulí 2019-09-03 11:17:39 UTC
(In reply to Julien Nabet from comment #3)
> (In reply to Julien Nabet from comment #2)
> >...
> > Should I make the change into 6.2 repo?
> > https://translations.documentfoundation.org/de/libo62_ui/translate/
> > #search=T~abelle&sfields=source,target
> 
> I finally also did the change in 6.2 branch.
> If it causes some pb, don't hesitate to revert or to ask me to revert.

Hi Julien,
Should this issue be closed then ?
Comment 5 Julien Nabet 2019-09-03 12:17:12 UTC
Indeed, let's close this one but as always, I don't know when it'll be present on translations repo.
(Also, I don't succeed in finding some information about Pootle -> Weblate LO migration)
Comment 6 Markus 2019-09-03 17:06:18 UTC
Is it possible to reproduce the solution manually (e.g. copying / editing a config file or whatever)?
Or do we have to wait until - sometime in the future - the change will be delivered via Linux (Mint 19.2) update!?
Comment 7 Julien Nabet 2019-09-03 17:08:44 UTC
(In reply to Markus from comment #6)
> Is it possible to reproduce the solution manually (e.g. copying / editing a
> config file or whatever)?
> Or do we have to wait until - sometime in the future - the change will be
> delivered via Linux (Mint 19.2) update!?

I don't think so but am not a translation expert.
Comment 8 Markus 2019-09-07 08:47:37 UTC
I can confirm now, that the problem has been solved: In the meanwhile LO has (automatically) been updated to version 6.3.1.2 where Alt + "t" works perfect.

Thanks everyone, especially Julien, for the quick solution!!!