Bug 127184 - AUTO CAPTION: Problems with Image Caption “Figure” in German UI
Summary: AUTO CAPTION: Problems with Image Caption “Figure” in German UI
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, possibleRegression
: 127404 (view as bug list)
Depends on:
Blocks: AutoCaption
  Show dependency treegraph
 
Reported: 2019-08-27 12:52 UTC by Pit Zaclade
Modified: 2019-09-19 13:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot as requested in comment 2 (138.51 KB, image/jpeg)
2019-08-28 17:03 UTC, Dieter
Details
This file demonstrates the bug (5.07 MB, application/vnd.oasis.opendocument.text)
2019-08-28 21:29 UTC, Pit Zaclade
Details
another test file (207.29 KB, application/vnd.oasis.opendocument.text)
2019-09-19 13:17 UTC, Pit Zaclade
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pit Zaclade 2019-08-27 12:52:41 UTC
Description:
I am using the German version of writer.
If I put the word “Figure” in (German) writer Tools→ Options→ LibreOffice Writer→ AutoCapture→ LibreOffice Writer Image
and insert one or more images, save the file, close the file and reopen this file then the number range is corrupt:
strg+F9 shows not the “Number range Figure” than an other Number range and a further new inserted picture starts repeated with “Figure 1”.
But if I am using “Gigure”, “figure” or an other word for Image caption, than there is no bug.
This bug is only in the German version of writer.


Steps to Reproduce:
1.put the word “Figure” in (German) writer Tools→ Options→ LibreOffice Writer→ AutoCapture→ LibreOffice Writer Image
2.insert one or more images, save the file
3.close the file and reopen this file then the number range is corrupt

Actual Results:
strg+F9 shows not the “Number range Figure” than an other Number range and a further new inserted picture starts repeated with “Figure 1”.

Expected Results:
"Number range Figure" is saved and a new image become a number=last number +1 (In the German version of writer!)


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2019-08-27 13:53:35 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build-ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

but not with

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 Julien Nabet 2019-08-28 15:14:30 UTC
On Win10 with master sources updated today + German localisation, I don't succeed in reproducing this.

Could someone attach a screenshot of "Automatsiche Beschriftung" for "Libreoffice Writer Bild"?

Indeed, I added "Figure" in first "Trenner" so it's ": Figure".
Comment 3 Dieter 2019-08-28 17:03:33 UTC
Created attachment 153715 [details]
Screenshot as requested in comment 2
Comment 4 Pit Zaclade 2019-08-28 21:12:12 UTC
The problem is not, that you can not produce "Figure" for AutoCapture (in German Version of writer), but if you save, close and reopen the file, then the AutoCapture is corrupt. Any further image starts with Figure 1 and the old AutoCapture to seen with strg+F9 are not "Figure ...".
Therefore the screenshot of Dieter cannot demonstrate the bug.
Comment 5 Pit Zaclade 2019-08-28 21:29:07 UTC
Created attachment 153721 [details]
This file demonstrates the bug
Comment 6 Oliver Brinzing 2019-09-06 18:35:06 UTC
*** Bug 127404 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2019-09-18 11:18:27 UTC
@Heiko, do you think it's related to the caption renaming done in 6.2 ?
Comment 8 Heiko Tietze 2019-09-19 06:52:59 UTC
Running LibO Stable 6.2.7, the default name for the category is "Abbildung" (which is what we changed from Illustration to Figure) and this works. If you open a document that was created before it uses Illustration (with the respective translation). Point is, I wonder why Pit has "Figure" in this dialog.
Comment 9 Pit Zaclade 2019-09-19 07:33:36 UTC
I have not said that "Figure" ist the default in the German version. That is no true.
And the "Figure" is not started in my own intention, but an friend in mind has this problem.
Comment 10 Heiko Tietze 2019-09-19 08:09:20 UTC
(In reply to Pit Zaclade from comment #9)
> I have not said...

No accusation, I just mentioned what has been done (Illustration was renamed to Figure). What you can do is to double check the entry at Tools > Options and test with a new document.
Comment 11 Pit Zaclade 2019-09-19 13:17:01 UTC
Created attachment 154292 [details]
another test file