Download it now!
Bug 127185 - Using a Citation in Writer, saving and reopening makes it appear CITATION
Summary: Using a Citation in Writer, saving and reopening makes it appear CITATION
Status: RESOLVED DUPLICATE of bug 105367
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bibliography DOCX
  Show dependency treegraph
 
Reported: 2019-08-27 13:18 UTC by dav9597
Modified: 2019-09-03 09:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
This is a sample of the bug mentioned in the OP (4.27 KB, text/plain)
2019-09-02 06:51 UTC, dav9597
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dav9597 2019-08-27 13:18:31 UTC
Description:
Using 6.3.0.4, inserting a citation in Writer and then saving/re-opening it, it creates the word CITATION attached to the short word used to "call" it. Anyone has a solution? Have a nice day everybody


Steps to Reproduce:
1 create a citation with author, article type, year, url and short word as reference
2 save document and close it
3 re-open it and check the citation
4 instead of [short_word] as normal, it is written [CITATION ""short_word""]

Actual Results:
showing [CITATION ""short_word""] as citation

Expected Results:
showing ["short_word"] as citation


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
Thread CPU: 4; SO: Windows 10.0; Resa interfaccia: default; VCL: win; 
Locale: it-IT (it_IT); Interface Language: it-IT
Calc: threaded
Comment 1 Dieter 2019-09-01 09:00:11 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 2 dav9597 2019-09-02 06:51:49 UTC
Created attachment 153809 [details]
This is a sample of the bug mentioned in the OP
Comment 3 dav9597 2019-09-02 06:53:45 UTC
(In reply to Dieter Praas from comment #1)

AS you can see, I created a sample document, and saving & re-opening creates the bug mentioned. Please check attached document.
Thank you and have a nice week :)
Comment 4 Dieter 2019-09-03 06:38:33 UTC
(In reply to davidedecandia from comment #3)
> (In reply to Dieter Praas from comment #1)
> 
> AS you can see, I created a sample document, and saving & re-opening creates
> the bug mentioned. Please check attached document.
> Thank you and have a nice week :)

I can see, it's a docx-file. Can you please also add the original odt-file? I don't know, how you produce the citation. Could you please specify step 1? thank you.
Comment 5 dav9597 2019-09-03 06:46:12 UTC
> I can see, it's a docx-file. Can you please also add the original odt-file?
> I don't know, how you produce the citation. Could you please specify step 1?
> thank you.

Thanks for replying

1 There's no need to upload the .odt file, because with that type of file, the bug doesn't occur.

2 to reproduce step 1:
Insert> general and analytic index> bibliographic voice (translated natively from italian, voice may change grammarly, but this is how you create a citation
Comment 6 Dieter 2019-09-03 09:12:42 UTC
Yes, I can confirm it, but I also found, that this bug is a duplicate of bug 105367

*** This bug has been marked as a duplicate of bug 105367 ***