Bug 127246 - In LibO Calc: tabbing in a protected sheet jumps far beyond last unprotected cell
Summary: In LibO Calc: tabbing in a protected sheet jumps far beyond last unprotected ...
Status: RESOLVED DUPLICATE of bug 126904
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-08-30 19:41 UTC by Euler German
Modified: 2019-08-31 08:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sheet sample (headings removed) (289.91 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-08-30 21:35 UTC, Euler German
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Euler German 2019-08-30 19:41:46 UTC
I have several spreadsheets to which I enter data on unprotected cells. All the rest is marked as protected and/or protected+hide. When sheet protection is toggled ON tab should jump only to unprotected cells, not very far right and to PROTECTED cells.

I have downgraded to v6.2.4.2 (x64) that's working fine.
Comment 1 raal 2019-08-30 20:42:08 UTC
Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 2 Euler German 2019-08-30 21:35:57 UTC
Created attachment 153766 [details]
Sheet sample (headings removed)

The columns where data is informed are: A, B, D, H, J, L, N, R, T, X, Z, AD, and AF. A new tab after AF should return to A column's next line but goes a long jump right. After long jump it goes jumping sequentially for several protected cells when it then returns to A column.

Never notice this bug until version 6.3.0.
Comment 3 raal 2019-08-31 03:24:41 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin ; Could you possibly take a look at this one?
Thanks
 c5a668eb55c0000fe9b5ac32b4bf250325e12a67 is the first bad commit
commit c5a668eb55c0000fe9b5ac32b4bf250325e12a67
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Apr 5 17:05:02 2019 +0200

    source sha:7282014e362a1529a36c88eb308df8ed359c2cfa

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-02-01 15:15:16 +0100
committer	Mike Kaganski <mike.kaganski@collabora.com>	2019-04-05 13:43:52 +0200
commit 7282014e362a1529a36c88eb308df8ed359c2cfa (patch)
tree 2776ad9601f494330076ac58c08554e719c6ab3a
parent df30a4515b1303b0891baa53754fa9b3e47e0c02 (diff)
tdf#50916 Makes numbers of columns dynamic.
Comment 4 Oliver Brinzing 2019-08-31 08:54:14 UTC
i think, this issue is a duplicate of:

Bug 126904 - In LO Calc: Right arrow causes a large unexpected column jump in protected sheet.

*** This bug has been marked as a duplicate of bug 126904 ***