Bug 127308 - FILESAVE: PPTX: Transparency is applied to gradient after RT
Summary: FILESAVE: PPTX: Transparency is applied to gradient after RT
Status: RESOLVED DUPLICATE of bug 127372
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pptx, regression
Depends on:
Blocks:
 
Reported: 2019-09-03 11:35 UTC by Xisco Faulí
Modified: 2019-09-05 14:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-09-03 11:35:10 UTC
Steps to reproduce:
1. Open attachment 42675 [details] from bug 33672
2. Save it as PPTX
3. Open the generated file

-> Gradients in shape have 50% transparency

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 2b4efc32e822bf41c4b729137718f3c70f692a89
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-09-03 11:36:20 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=599ae1151bf893491db7ad983d64c77521c3ae9d

author	Miklos Vajna <vmiklos@collabora.com>	2019-07-01 21:10:01 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2019-07-02 09:06:37 +0200
commit 599ae1151bf893491db7ad983d64c77521c3ae9d (patch)
tree a3d67407d93b694c48a6660991bfc9d387a996d8
parent 7d32994ad9dc45c7846664ec5ccb03bb796bb071 (diff)
tdf#125554 PPTX export: handle gradient transparency for gradient fill

Bisected with: bibisect-linux64-6.4

Adding Cc: to Miklos Vajna

[Bug found by office-interoperability-tools]
Comment 2 Xisco Faulí 2019-09-03 11:38:18 UTC
Also reproduced with attachment 119814 [details] from bug 95211
Comment 3 Xisco Faulí 2019-09-03 11:39:51 UTC
and attachment 50052 [details] from bug 39948
Comment 4 Xisco Faulí 2019-09-03 11:43:55 UTC
attachment 76434 [details] from bug 62256 is also affected
Comment 5 Xisco Faulí 2019-09-05 14:50:17 UTC
Tamás is taking care of it in bug 127372

*** This bug has been marked as a duplicate of bug 127372 ***