Bug 127360 - UI: horizontal scroll in Calc on MacOS doesn't respect system settings
Summary: UI: horizontal scroll in Calc on MacOS doesn't respect system settings
Status: RESOLVED DUPLICATE of bug 126680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-05 10:09 UTC by Joachim
Modified: 2019-09-05 14:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim 2019-09-05 10:09:31 UTC
Description:
Horizontal scroll in Calc on MacOS doesn't respect system settings if Natural scrolling is disabled.

Steps to Reproduce:
1. Configure the MacOS system prefs to use 'classic' scroll direction, that is, unselect 'Natural scrolling'.
2. With 6.3.0, open a Calc spreadsheet. 
3. Use the magic mouse / trackpad to scroll vertically: the scroll behaves as expected.
4. Use the magic mouse / trackpad to scroll horizontally: the scroll is in the wrong direction.


Actual Results:
Swiping right in the document moves the document to the left: cells to the left become visible.

Expected Results:
Swiping right in the document moves the document to the right: cells to the right become visible.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Rob Powers 2019-09-05 13:42:45 UTC
I see this same problem with Calc. Also occurs with 6.3.0.4 using Writer and Impress (presumably all app components).

Note: the vertical scroll *does* behave as expected with the MacOS system setting set to "classic" mode.
Comment 2 Rob Powers 2019-09-05 13:44:10 UTC
(In reply to Rob Powers from comment #1)
> I see this same problem with Calc. Also occurs with 6.3.0.4 using Writer and
> Impress (presumably all app components).
> 
> Note: the vertical scroll *does* behave as expected with the MacOS system
> setting set to "classic" mode.


Observed on MacOS Mojave 10.14.6
Comment 3 trainman75 2019-09-05 14:05:38 UTC
I had that issue for a while too, and it appears this is a duplicate of the now-resolved https://bugs.documentfoundation.org/show_bug.cgi?id=126680
Maybe have a read through the comments thread for that one and see if it gets fixed for you, especially note comment 20.
Comment 4 Aron Budea 2019-09-05 14:06:36 UTC
Yep, let's assume it's a duplicate, updating to 6.3.1 should fix this issue.

*** This bug has been marked as a duplicate of bug 126680 ***