Bug 127372 - PPTX: Shape's background transparency changes during RT
Summary: PPTX: Shape's background transparency changes during RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords: bibisected, bisected, filter:pptx, regression
: 127308 127737 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-05 13:33 UTC by Tamás Zolnai
Modified: 2019-09-24 10:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
ODP file (12.70 KB, application/vnd.oasis.opendocument.presentation)
2019-09-05 13:33 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2019-09-05 13:33:02 UTC
Description:
The attached test document has a shape with gradient fill without any transparency. After saving to PPTX and reload, the document gets a linear transparency too. The filling blue background become white at the bottom of the shape.

Steps to Reproduce:
1. Open attached ODP file
2. Save to PPTX
3. Close and reload PPTX
4. Check shape's background fill

Actual Results:
There is an extra linear transparency set.

Expected Results:
Transparency should be null, same as in the ODP file.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tamás Zolnai 2019-09-05 13:33:59 UTC
Created attachment 153919 [details]
ODP file
Comment 2 Xisco Faulí 2019-09-05 14:49:56 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=599ae1151bf893491db7ad983d64c77521c3ae9d, which is the same as in bug 127308
Comment 3 Xisco Faulí 2019-09-05 14:50:17 UTC
*** Bug 127308 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2019-09-06 06:00:44 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0417fb9ccd5a5467107621b5ac5ba1edcda71c68%5E%21

tdf#127372: PPTX: Shape's background transparency changes during RT

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2019-09-09 22:47:57 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: f4f8bccbd4e2c3979a83d5b2f49e16a99a3a2016
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tamás Zolnai, thanks for fixing this issue!
Comment 6 Commit Notification 2019-09-09 23:43:00 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/278a60fe7bd2254a7c09c9d32317ff4f2aab752f%5E%21

tdf#127372: PPTX: Shape's background transparency changes during RT

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-09-24 10:22:08 UTC
*** Bug 127737 has been marked as a duplicate of this bug. ***