Download it now!
Bug 127376 - Incorrect import of this .svg image
Summary: Incorrect import of this .svg image
Status: RESOLVED DUPLICATE of bug 99562
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:svg
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2019-09-05 14:05 UTC by Frederic Parrenin
Modified: 2019-09-19 08:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.svg image to demonstrate the problem (366.88 KB, image/svg+xml)
2019-09-05 14:05 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2019-09-05 14:05:48 UTC
Created attachment 153924 [details]
.svg image to demonstrate the problem

Steps to reproduce:
- open Impress
- insert the attached .svg image
=> the image misses the colored shaded. See it with other image viewer/editor like inkscape or eog for a comparison.
Comment 1 Roman Kuznetsov 2019-09-05 18:46:23 UTC
confirm in

Версия: 6.4.0.0.alpha0+
ID сборки: 2bed8af91fc2654b9ed2432f969d32d5741a529b
Потоков ЦП: 4; ОС:Linux 5.2; Отрисовка ИП: по умолчанию; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-08-21_09:30:10
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded
Comment 2 V Stuart Foote 2019-09-05 20:06:54 UTC
Isn't this more of the same clip-path & masking issues of bug 97657 and dupes?
Comment 3 Xisco Faulí 2019-09-18 10:52:38 UTC
Same issue as in bug 99562.
The svg was fine until https://cgit.freedesktop.org/libreoffice/core/commit/?id=ecc7f698b5f080530f006218fa3dd82da43d9abb, the problem is

    <mask
       id="mask0">
      <g
         id="g1056"
         style="filter:url(#alpha)">

which uses URL, and it's not supported ( bug 94765 )
I plan to take a look at it when I have some time...

*** This bug has been marked as a duplicate of bug 94765 ***
Comment 4 Xisco Faulí 2019-09-19 08:37:38 UTC
This is a dupe of bug 99562, not bug 94765

*** This bug has been marked as a duplicate of bug 99562 ***