Bug Hunting Session
Bug 127379 - PPTX: Gradient background fill of a slide is lost during RT.
Summary: PPTX: Gradient background fill of a slide is lost during RT.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.4.0
Keywords: filter:pptx
: 123101 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-05 16:35 UTC by Tamás Zolnai
Modified: 2019-09-09 23:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODP file (19.67 KB, application/vnd.oasis.opendocument.presentation)
2019-09-05 16:35 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2019-09-05 16:35:09 UTC
Description:
If a slide in a PPTX file has gradient fill, it changes to no fill after RT.
See the test document. It contains both a master slide having such fill and normal slide with the same issue.

Steps to Reproduce:
1. Open the atteched ODP file
2. Save it to PPTX
3. Close and reload the PPTX file
4. Check the two slides's background color

Actual Results:
The two slides should have gradient fill.

Expected Results:
The two slides have white background.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tamás Zolnai 2019-09-05 16:35:50 UTC
Created attachment 153929 [details]
ODP file
Comment 2 Xisco Faulí 2019-09-05 17:02:53 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e
Comment 3 Commit Notification 2019-09-06 06:00:55 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ced915bf4c4dfc890193bbea269ef74995ecc888%5E%21

tdf#127379: PPTX: Gradient background fill of a slide is lost during RT.

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2019-09-09 23:02:01 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: f4f8bccbd4e2c3979a83d5b2f49e16a99a3a2016
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tamás Zolnai, thanks for fixing this issue!
Comment 5 Xisco Faulí 2019-09-09 23:04:38 UTC
*** Bug 123101 has been marked as a duplicate of this bug. ***