Bug 127382 - Digital Signature for at least 6.2.7.1 msi is going to expire on 2019-09-05 21:00
Summary: Digital Signature for at least 6.2.7.1 msi is going to expire on 2019-09-05 2...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-05 18:53 UTC by himajin100000
Modified: 2019-09-18 10:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description himajin100000 2019-09-05 18:53:04 UTC
Description:
Message may not be the same as the original English string. I'm using Japanese version.

Download 6.2.7.1 LibreOffice installer
From context menu on msi file, choose Properties
Click "Digital Signatures" Tab
Click the only certificate from tdf
Click Details
Click Show Certificate
See Valid date




Steps to Reproduce:
see description

Actual Results:
The valid date ends on 2019-09-05 21:00 (UTC?)

Expected Results:
Certificate with longer valid date is used.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 himajin100000 2019-09-06 15:43:22 UTC
A user says he cannot install LibreOffice, but honestly speaking, I cannot reproduce such non-installability
Comment 2 JO3EMC 2019-09-08 05:35:08 UTC
It seems to be same situation also in 6.3.1 and the other older msi(6.2.6, 6.3.0).

Non-installability hasn't been reproduced in my environment(Win10 home) too.
Comment 3 Xisco Faulí 2019-09-18 10:21:47 UTC
Conversation from IRC:

<x1sc0> cloph, can tdf#127382 be closed as RESOLVED since the certificate has been updated ?
<IZBot> LibreOffice-Installation normal/medium NEW Digital Signature for at least 6.2.7.1 msi is going to expire on 2019-09-05 21:00 https://bugs.documentfoundation.org/show_bug.cgi?id=127382
<cloph> that is notabug, since existing signatures won't loose validility just because the certificate cannot be used for new ones, but yes, not an issue in any case.
<x1sc0> thanks

closing as RESOLVED NOTABUG