Bug 127385 - Docs for html meta tags describe non-existent File->Properties->"User Defined" tab
Summary: Docs for html meta tags describe non-existent File->Properties->"User Defined...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Olivier Hallot
URL:
Whiteboard: target:7.3.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2019-09-06 00:30 UTC by Jim Avera
Modified: 2021-09-13 07:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2019-09-06 00:30:23 UTC
Description:
The Help text for Export as HTML (file://...opt/libreofficedev6.4/help/en-US/text/shared/01/about_meta_tags.html?DbPAR=SHARED#bm_id3154380 on my system) says the following:

"To set the properties of the current document, choose File - Properties, click the Description or User Defined tabs, and then type the information you want."

However, File->Properties does not have a "User Defined" tab.

P.S. What I really want is to know how insert a "viewport" meta tag into the result of Export-to-HTML.   See https://developers.google.com/web/fundamentals/design-and-ux/responsive/?hl=en  
I tried the 'Custom Properties' tab, creating an item with Name=viewport Type=Text and Value=width=device-width, initial-scale=1 but it die not appear in the output when exporting to html.

Steps to Reproduce:
1. Help->LibreOffice Help
2. Type "meta" into the search box, then click "META tags" in the GLOBAL search results list which appears immediately
3. Follow the instructions to (try to) define a meta tag

Actual Results:
You can't because the instructions refer to a non-existent tab.

Expected Results:
Document how to define a META tag which will end up in the output of export-to-html.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Jim Avera 2019-09-06 20:21:57 UTC
Forgot to mention: I was using a writer doc (.odt), trying to get a META tag in the output from export-to-html
Comment 2 Olivier Hallot 2019-12-27 18:48:53 UTC
I checked that Custom properties are saved into meta tags when SAVING a text document (odt) in html format. 

For example, with metas (aaa,bbb) and (Ccc,ddd) I get
(...)
        <meta name="changedby" content="Olivier Hallot"/>
        <meta name="changed" content="2019-12-27T15:40:17.876396188"/>
        <meta name="Ccc" content="ddd"/>
        <meta name="aaa" content="bbb"/>
        <style type="text/css"> 
(...)

When EXPORTING to (x)html, these metatags are absent.

The help page https://help.libreoffice.org/6.3/en-US/text/shared/01/about_meta_tags.html?DbPAR=SHARED#bm_id3154380

AKA text/shared/01/about_meta_tags.xhp need to be revisited and updated.
Comment 3 Olivier Hallot 2021-09-06 12:59:21 UTC
The help page refers to exporting HTML meta tags for command Save As with file type  HTML. The  "Name=viewport Type=Text and Value=width=device-width, initial-scale=1" meta tag can be inserted in the Custom Properties.

XHTML export does not handle custom properties (enhancement?)
Comment 4 Jim Avera 2021-09-06 22:21:13 UTC
> The help page refers to exporting HTML meta tags for command Save As with file type  HTML.

The linked-to help page unambiguously says it is about "Export" not "Save", so at least this is a documentation bug.   Assuming behavior is as intended.
Comment 5 Commit Notification 2021-09-07 12:02:47 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/5910cbd9619da6f850da070babb75abd6d334806

tdf#127385 Update HTML <meta> export.
Comment 6 Olivier Hallot 2021-09-13 07:24:13 UTC
Closing, fixed.

About the P.S. of comment#0 , please open a specific bug for.