Bug 127393 - horizontal line chart label needs space on both ends
Summary: horizontal line chart label needs space on both ends
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:6.4.0
Keywords: implementationError
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2019-09-06 05:58 UTC by nd101
Modified: 2019-12-10 16:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample document (58.96 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-09-06 05:59 UTC, nd101
Details
in Impress (17.74 KB, image/png)
2019-09-06 05:59 UTC, nd101
Details
in mSO (15.29 KB, image/png)
2019-09-06 06:00 UTC, nd101
Details
sample compared MSO LO (120.17 KB, image/png)
2019-10-07 12:56 UTC, Timur
Details
sample saved in MSO as PPT (154.50 KB, application/vnd.ms-powerpoint)
2019-12-10 15:49 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nd101 2019-09-06 05:58:37 UTC
In MSO, it leaves a little space both ends of the horizontal line, and it looks nice. In Impress, it labels differently
Comment 1 nd101 2019-09-06 05:59:10 UTC
Created attachment 153955 [details]
sample document
Comment 2 nd101 2019-09-06 05:59:40 UTC
Created attachment 153956 [details]
in Impress
Comment 3 nd101 2019-09-06 06:00:06 UTC
Created attachment 153957 [details]
in mSO
Comment 4 nd101 2019-09-06 06:31:56 UTC Comment hidden (obsolete)
Comment 5 Gabor Kelemen (allotropia) 2019-09-09 13:50:42 UTC
Confirming with

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 9670abc43051e1f7a3f2ed9369ca9a3748aa7a2b
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-09-09_06:46:04
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

It has worked like this in: 

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 6 Timur 2019-09-16 10:35:29 UTC
Started in LO 3.3. OO didn't show chart at all.
Comment 7 Commit Notification 2019-09-23 13:54:08 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/830e539547c463b932ce643517f880789185032d

tdf#127393 OOXML chart import: fix X axis position setting "CrossBetween"

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Timur 2019-10-07 12:56:39 UTC
Created attachment 154797 [details]
sample compared MSO LO

OK
Comment 9 Timur 2019-10-07 13:08:01 UTC
*** Bug 127396 has been marked as a duplicate of this bug. ***
Comment 10 Timur 2019-12-10 15:49:43 UTC
Created attachment 156454 [details]
sample saved in MSO as PPT

Sample attachment 153955 [details] was PPTX, but I also checked MSO-saved PPT and it's also OK. Attaching here. 

Sample attachment 153964 [details] from duplicated bug 127396 is OK for space on ends, but it doesn't show horizontal labels (I'll reopen it for that). I also checked MSO-saved PPT and it's all OK.

There's XLS attachment 93463 [details] from bug 74576 that I think exhibits similar bug. I'll open a new one for that.