Bug 127411 - Broken mouse status in Impress status bar
Summary: Broken mouse status in Impress status bar
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.3 target:6.3.4
Keywords: bibisected, bisected, regression
: 125512 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-06 15:21 UTC by Mike Kaganski
Modified: 2019-10-25 17:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Status bar of Impress (4.18 KB, image/png)
2019-09-06 15:21 UTC, Mike Kaganski
Details
How it looks in LibreOffice 6.4 master (139.58 KB, image/png)
2019-09-26 11:38 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-09-06 15:21:22 UTC
Created attachment 153992 [details]
Status bar of Impress

I was in the process of preparing my slides for LibOCon using Version: 6.3.1.2 (x64)
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
, but SUDDENLY!!!1111 a disaster happened: in the status bar, I saw something frightening - as shown on the screenshot!!!!!

I had a revelation (caused by "bibisection" incantation) that that's caused by https://git.libreoffice.org/core/+/c53f3f8f58f55d0978fb968446975856d72a52f8.

How can I survive this??? PLEASE PLEASE FIX THIS ASAP, my life depends on this!!! (or not...?)

:-)
Comment 1 V Stuart Foote 2019-09-07 02:47:07 UTC
Riviting! Oh the misery, sure hope your fates can be salvaged...

Anyhow, confirmed on Windows 10 Home 64-bit en-US (1903) with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_22:04:10
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Commit Notification 2019-09-25 16:04:12 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d513a845cf73e55aa88be716fcb7a1f98cd054b1

tdf#127411 Broken mouse status in Impress status bar

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2019-09-26 11:38:18 UTC
Actually the behaviour is better after c53f3f8f58f55d0978fb968446975856d72a52f8, but not as good as it used to be... I'll attach a screenshot
Comment 4 Xisco Faulí 2019-09-26 11:38:44 UTC
Created attachment 154539 [details]
How it looks in LibreOffice 6.4 master
Comment 5 Xisco Faulí 2019-09-26 11:40:30 UTC
Second decimal digit is not displayed and there's no space between one element and the other
Comment 6 Commit Notification 2019-09-26 13:58:18 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/477c724c78169087077837336afb58c1e4419181

tdf#127411 Broken mouse status in Impress status bar

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-10-16 14:52:56 UTC
*** Bug 125512 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2019-10-24 11:06:05 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/faa4ebb2cdc99505e9be7e1cbed83b19acfd3c4a

tdf#127411 improve sizing of status items in the status bar

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-10-24 14:45:34 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/e63d60c90d465ea6d9177bb82c25a35185a05a6e

tdf#127411 improve sizing of status items in the status bar

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2019-10-25 17:30:37 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: c0b8be4d7eb9fa1a0d8abfb1d27c71ac34bffd1b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, thanks for fixing this issue!