Download it now!
Bug 127432 - Cycle Caps function affects previous word when word begins with numbers.
Summary: Cycle Caps function affects previous word when word begins with numbers.
Status: RESOLVED DUPLICATE of bug 49033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-08 02:32 UTC by J. Deck
Modified: 2019-09-08 05:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J. Deck 2019-09-08 02:32:09 UTC
Description:
When the selected word begins with numerals, and the Cycle Case function is used, on the cycle that is expected to produce Title case, is it applied to the previous word.

Steps to Reproduce:
1.In a new document, type the following two strings with capitalization and spacing exactly as shown:
abCd 123xyx

2. Position cursor between the "x" and the "y", or select the entire second string
3. Type the Shift+F3 keyboard shortcut repeatedly.


Actual Results:
The previous word is title-cased.

Expected Results:
The case only of the selected word should be changed.


Reproducible: Always


User Profile Reset: No



Additional Info:
- It seems to be important that the second string begin with numeric characters.

- Repeated presses of Shift+F3 will change capitalization in the selected word. However, on the cycle that should produce title caps, the previous (all-alphabetic) word instead is set to title caps.

- This might be related to bug 49033; at least, commend #62 on that bug seems to be about something similar.

Version: 6.3.0.4 (x86)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 V Stuart Foote 2019-09-08 05:32:35 UTC
Add an extra "word", you'll then see the abCd cycle through the initial caps and not end with title case. With just the two words it has notihing to do with start of second work being a number--rather it is just the roll through Sentence case.

*** This bug has been marked as a duplicate of bug 49033 ***