Download it now!
Bug 127449 - Edit->Find in LibreOffice Calc returns "search key not found" when the search term contains an apostrophe.
Summary: Edit->Find in LibreOffice Calc returns "search key not found" when the search...
Status: RESOLVED DUPLICATE of bug 116763
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-09 09:25 UTC by txman201
Modified: 2020-06-14 12:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple Calc sheet with text cells for search, cells contain a text apostrophe (14.24 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-09-20 14:52 UTC, txman201
Details
apostrophe copied to text file (9.46 KB, image/png)
2019-09-20 17:10 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description txman201 2019-09-09 09:25:11 UTC
Description:
Windows 10, LibreOffice Version: 6.2.7.1 (x64). All columns are formatted as text. A cell contains text:  What Doesn't Kill Her
Using Edit->Find to locate that string returns "search key not found". Experimentation revealed that changing the text to What Doesnt Kill Her results in Edit->Find locating the key when the apostrophe is removed from both the cell and the search term. I also found that a search for What Doesn will correctly find the cell when the apostrophe is present in the text string. It appears that the presence of the apostrophe is disrupting to the Find command.

Steps to Reproduce:
1. Format one or more cell as text. (I use USA-English.)
2. Enter text that contains an apostrophe.  (My case was the word Doesn't.)
3. Use Edit-> Find to locate all cells containing the text Doesn't.

Actual Results:
Edit->Find returns "search key not found".
If I change the text by removing the apostrophe from the cell (Doesnt) and then search for that modified text, the cell is correctly identified by the command.

Expected Results:
Expected the Find to move the focus to the line in the spreadsheet that contains the search term.  In all cases for search strings WITHOUT an apostrophe in the string, the Find works correctly. It appears that any search term containing an apostrophe will result in "search key not found".


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.7.1 (x64)
Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 m.a.riosv 2019-09-11 11:12:18 UTC
Last working for me
Versión: 5.0.0.0.beta2 (x64)Id. 900960d3e4220f7e04f45c9bf45a1cd92cd06affFirst not First not working for me.
Versión: 5.1.0.3 (x64) Id.: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737

Doesn't work writing the text in the Found box, but works copying the text from a cell.
Comment 2 raal 2019-09-20 13:06:31 UTC
I can not reproduce with Version: 6.4.0.0.alpha0+ (x64)
Build ID: 0d90da9ea0a23c9c4afac62025208559b1496a0e
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 

Seems to be fixed with dev version. Please could you test it with dev version?  You can download it here: http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 3 txman201 2019-09-20 14:25:04 UTC
(In reply to raal from comment #2)
> I can not reproduce with Version: 6.4.0.0.alpha0+ (x64)
> Build ID: 0d90da9ea0a23c9c4afac62025208559b1496a0e
> CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
> 
> Seems to be fixed with dev version. Please could you test it with dev
> version?  You can download it here:
> http://dev-builds.libreoffice.org/daily/master/
> Thank you

I uninstalled the release version I had been using, then did a complete shutdown and cold boot. I then installed (I believe) what you asked.  Here is the info from "About":

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 4342aaef0c4d6cd5c51fd2b74328bb4df5fb71dd
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-20_06:31:38
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

I used the original file where the defect was noted, as well as a much smaller file as test files.  The newer version I installed does act different in that when a search string is not found, the text string typed into the search box changes to a red font. This is new, so it confirms I am running the new install.

It still fails for me.  Here is detail.
Test string typed into a cell is:   What Doesn't Kill Her
Search for this fails. I get same "Search Key not found" return.
I also tried text "Don't Kill Her" just for fun. Same defect.
If I search for text string stopping before the apostrophe shown in the cell, it always finds the cell.
Example:  Search for text Doesn will find the cell with "What Doesn't Kil Her".
As noted by another comment, after I type the string into a cell, if I copy that string, and paste THAT into the search box, the search completes successfully.

I was very careful in my test procedure, so I believe I am not introducing any operator error.
Comment 4 raal 2019-09-20 14:29:24 UTC
Please attach test file. Thanks
Comment 5 txman201 2019-09-20 14:52:42 UTC
Created attachment 154327 [details]
Simple Calc sheet with text cells for search, cells contain a text apostrophe

Copying the text from the cells then pasting into the search box returns the expected result.

Typing the same text into the search box fails.
Comment 6 raal 2019-09-20 17:10:57 UTC
Created attachment 154331 [details]
apostrophe copied to text file

Looks like apostrophe  written and apostrophe in the file are not identical.

I can reproduce with Version: 6.4.0.0.alpha0+
Build ID: 0d90da9ea0a23c9c4afac62025208559b1496a0e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 7 Buovjaga 2020-06-14 12:56:48 UTC
This is not a regression. Closing as dupe of a Writer issue.

*** This bug has been marked as a duplicate of bug 116763 ***