Download it now!
Bug 127456 - Draw: Orientation of image changes when exporting to PDF
Summary: Draw: Orientation of image changes when exporting to PDF
Status: RESOLVED DUPLICATE of bug 117398
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2019-09-09 19:39 UTC by Hyogapag
Modified: 2019-09-23 15:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The guilty file (896.55 KB, application/vnd.oasis.opendocument.graphics)
2019-09-09 19:42 UTC, Hyogapag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hyogapag 2019-09-09 19:39:50 UTC
Description:
With LO Draw, I have made a file where I included a PDF as an image. When exporting this file to PDF format, the orientation of the included image rotates of 90 degrees counterclockwise. 

Steps to Reproduce:
1. Open the attached file
2. Export it to PDF

Actual Results:
The orientation of the picture changes.

Expected Results:
It shouldn't.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.2.6.2
Build ID: 1:6.2.6-0ubuntu0.19.04.1
Threads CPU : 4; OS : Linux 5.0; UI Render : GL; VCL: kde5; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 1 Hyogapag 2019-09-09 19:42:35 UTC
Created attachment 154063 [details]
The guilty file
Comment 2 Durgapriyanka 2019-09-09 22:16:13 UTC
Thank you for reporting the bug, I can reproduce this bug in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Timur 2019-09-17 06:57:42 UTC
No repro 5.0. Repro 5.4 and 6.4+. Seems regression.
Comment 4 Xisco Faulí 2019-09-23 15:41:52 UTC
Before https://cgit.freedesktop.org/libreoffice/core/commit/?id=1ec8557d86d53c9df5afd5607a953ec72c33702f, it was exported as displayed in attachment 141467 [details], then the export is broken for some commits, and finally it works again after https://cgit.freedesktop.org/libreoffice/core/commit/?id=242a9b634213acf03cabc373928555dc81afc672, when the output is already incorrect

Closing as a duplicate of bug 117398

*** This bug has been marked as a duplicate of bug 117398 ***