Download it now!
Bug 127514 - Tabbed UI messed up in master 6.4+ (only Windows build @42 both x86 and x64)
Summary: Tabbed UI messed up in master 6.4+ (only Windows build @42 both x86 and x64)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2019-09-12 10:03 UTC by Timur
Modified: 2019-11-01 14:04 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Tabbed UI compared (85.51 KB, image/jpeg)
2019-09-12 10:03 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2019-09-12 10:03:07 UTC
Created attachment 154129 [details]
Tabbed UI compared

Tabbed UI is messed up in master 6.4+. 
Seen in Calc and Writer in Windows with libo-master~2019-09-10_01.24.04_LibreOfficeDev_6.4.0.0.alpha0_Win_x86. 
This build is OK:
master~2019-09-01_22.04.10_LibreOfficeDev_6.4.0.0.alpha0_Win_x64_en-US_de_ar_ja_ru_vec_qtz

I can wait for another build, but it would good that others also test it.
Comment 1 Sumit Chauhan 2019-09-12 11:25:32 UTC
@mikekaganski ,I think this bug is caused by https://gerrit.libreoffice.org/#/c/78424/. It might not be able to create customwidget in windows.
Comment 2 Julien Nabet 2019-09-12 12:34:55 UTC
Just for the record, on Win10 with master sources updated today, I don't reproduce this.
Comment 3 Sumit Chauhan 2019-09-12 12:44:15 UTC Comment hidden (obsolete)
Comment 4 Julien Nabet 2019-09-12 12:45:22 UTC Comment hidden (obsolete)
Comment 5 Sumit Chauhan 2019-09-12 12:48:24 UTC
(In reply to Julien Nabet from comment #4)
> (In reply to Sumit Chauhan from comment #3)
> > (In reply to Julien Nabet from comment #2)
> > ...
> > did you clear the user profile ?
> Yes
 
I was unable to produce it until I downloaded https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/  this build.It would be great if you comfirm for this build too.

Thanks
Comment 6 Julien Nabet 2019-09-12 13:00:36 UTC
I've already LO 6.3.0.4 (that I must upgrade) + LO sources. I wouldn't like to mix too much LO versions.
Here's the latest commit I retrieved:
commit 78e369cc261fd83f2259a70b2589b928b59090f0 (HEAD -> master, origin/master, origin/HEAD)
Author: Miklos Vajna <vmiklos@collabora.com>
Date:   Wed Sep 11 23:48:25 2019 +0200

    desktop: mark LOKClipboard as final
Comment 7 andreas_k 2019-09-12 13:25:27 UTC Comment hidden (obsolete)
Comment 8 andreas_k 2019-09-12 13:25:43 UTC
this build work fine on win10

https://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/2019-09-11_05.46.53/
Comment 9 Timur 2019-09-12 14:16:49 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2019-09-17 13:51:42 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: c56bf1479cc71d1a2b0639f6383e90c1f7e3655b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: en-GB (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Xisco Faulí 2019-09-17 14:10:37 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha0+ (x64)
Build ID: d52010013b9cacdd8f71e62fef18c1e679e807f2
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

@Timur, Could you please try with a more recent master build ?
Comment 12 Timur 2019-09-18 06:26:19 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2019-09-26 13:37:45 UTC
(In reply to Timur from comment #12)
> Repro today. 
> Did you use 42 at
> https://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/ or
> https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/?

no, it was the bisect repository
Comment 14 Xisco Faulí 2019-10-22 13:51:36 UTC
Hi Timur,
Could this issue be closed or is it still reproducible in a master build ?
Comment 15 Timur 2019-10-23 06:41:08 UTC
It was only @42 but they are both empty now. 
If they will not be built further (because now there's Jenkins_tb77_x64), than it's up to you to close.
Comment 16 Timur 2019-11-01 10:49:21 UTC
I guess this is WontFix because Windows build @42 seem not to work anymore.
Now we have just @39 and @77 at https://dev-builds.libreoffice.org/daily/master/.
Xisco, if not so, please explain.
Comment 17 V Stuart Foote 2019-11-01 14:04:09 UTC
Remember seeing this briefly at some point, not sure if it was TB42 or not--OpenGL or default GDI. But otherwise now WFM on the TB77 builds.