Bug 127577 - Pivot table cells not updating when source data is updated
Summary: Pivot table cells not updating when source data is updated
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Pivot-Table
  Show dependency treegraph
 
Reported: 2019-09-16 14:19 UTC by Kat
Modified: 2020-05-12 03:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample data (11.16 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-09-17 08:38 UTC, Kat
Details
screenshot of update menuitem greyed out (11.08 KB, image/png)
2019-09-17 08:43 UTC, Kat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kat 2019-09-16 14:19:53 UTC
In 6.3.1.2, when I update the source data (using search and replace), the pivot table breaks.

Some of the cells in the pivot table update, some keep the old values and start showing values which have nothing to do with the old or new value.

I can't attach the specific document that I'm working on because it is confidential but it is essentially a bunch of columns with text labels and the issue is with the text labels rather than the processed data.
Comment 1 Oliver Brinzing 2019-09-16 17:19:39 UTC
Thank you for reporting the bug.

Have you tried to update via Menu "Data/Pivot Table/Refresh"?

> I can't attach the specific document that I'm working on 
> because it is confidential

Please attach a small sample document, and a detailed description how the bug can be reproduced as this makes it easier for us to verify the bug

(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 m.a.riosv 2019-09-16 21:15:04 UTC
Maybe you are changing the field names (column heads)?
Comment 3 Kat 2019-09-17 08:38:16 UTC
Created attachment 154213 [details]
sample data

(In reply to Oliver Brinzing from comment #1)
> Have you tried to update via Menu "Data/Pivot Table/Refresh"?

I can't because it's greyed out (regardless of which sheet I am looking at).

bearon said that it should update automatically (and if it doesn't, I think that would be a nice feature to have).

> Please attach a small sample document, and a detailed description how the
> bug can be reproduced as this makes it easier for us to verify the bug.

It's really easy to reproduce: change any value in Column4 (E), then look at the pivot table.

(In reply to m.a.riosv from comment #2)
> Maybe you are changing the field names (column heads)?

I don't know what the right terminology is, but it's cells E2:E17 in the attached doc.
Comment 4 Kat 2019-09-17 08:43:00 UTC
Created attachment 154214 [details]
screenshot of update menuitem greyed out
Comment 5 Oliver Brinzing 2019-09-17 18:00:46 UTC
(In reply to Kat from comment #3)
> > Have you tried to update via Menu "Data/Pivot Table/Refresh"?
> 
> I can't because it's greyed out (regardless of which sheet I am looking at).

you need to set the cell cursor inside the pivot table before.
there is also a context menu available with a "Refresh" entry.
Comment 6 Roman Kuznetsov 2019-10-13 20:56:36 UTC
Kat, can you retest your problem with advice from Oliver?
Comment 7 QA Administrators 2020-04-11 03:29:39 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2020-05-12 03:51:56 UTC
Dear Kat,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp