Download it now!
Bug 127603 - "Tools - Macros - Run macro.." help rendering with F1 is inconsistent
Summary: "Tools - Macros - Run macro.." help rendering with F1 is inconsistent
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Help-Link Macro-UI
  Show dependency treegraph
 
Reported: 2019-09-17 14:06 UTC by LibreOfficiant
Modified: 2020-10-28 16:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LibreOfficiant 2019-09-17 14:06:19 UTC
Description:
Impress / Writer / other component help pages appear instead of the dedicated help

Steps to Reproduce:
1. From the Launcher or an open .od* file
2. Select Tools - Macros - Run macro...
3. Press F1

Actual Results:
Writer / Impress / .. main help page displays

Expected Results:
Display a 'tools - Macros - Run macro..' dedicated help page


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-09-26 08:58:42 UTC
Thanks for reporting this issue.
Could you please check if it's a duplicate of bug 126007 and check whether it's fixed in LibreOffice 6.3.2 ?
Comment 2 LibreOfficiant 2019-09-30 12:32:13 UTC
(In reply to Xisco Faulí from comment #1)
> Thanks for reporting this issue.
> Could you please check if it's a duplicate of bug 126007 and check whether
> it's fixed in LibreOffice 6.3.2 ?

This is not a duplicate of 126007
It's not fixed with 6.3.2

Displayed help page should be:
help/fr/text/shared/01/06130000.html
Comment 3 Commit Notification 2019-10-18 19:18:29 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/e12593f8053bd1768c1f24b3f9213fb2bef204ef

tdf#127603 + refactor Basic/script dialogs Help pg
Comment 4 Buovjaga 2019-10-21 18:53:53 UTC
(In reply to Commit Notification from comment #3)
> Olivier Hallot committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/help/commit/
> e12593f8053bd1768c1f24b3f9213fb2bef204ef
> 
> tdf#127603 + refactor Basic/script dialogs Help pg

Why not give the new files human-readable names instead of 06130020 etc.?
Comment 5 Xisco Faulí 2019-12-03 10:53:41 UTC
A polite ping to Oliver Hallot:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
Otherwise, Could you please explain what's missing?
Thanks