Download it now!
Bug 127617 - FILEOPEN DOCX Different enter size, without character, makes the table row size greater than in Word
Summary: FILEOPEN DOCX Different enter size, without character, makes the table row si...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2019-09-18 08:31 UTC by NISZ LibreOffice Team
Modified: 2019-09-27 06:18 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
The example document in Word and Writer side by side. (67.93 KB, image/png)
2019-09-18 08:31 UTC, NISZ LibreOffice Team
Details
Example document from Word (24.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-09-18 08:32 UTC, NISZ LibreOffice Team
Details
Example compared MSO LO6.2 LO64+ (126.31 KB, image/jpeg)
2019-09-19 06:25 UTC, Timur
Details
The size of spaces is ignored.docx: created by MSOffice 2003, proves regression (10.31 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-09-24 12:40 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-09-18 08:31:00 UTC
Description:
In the attached minimized user made DOCX file the table has a cell where the character sizes are different . In Writer the cell size becomes taller than it is in Word.

Steps to Reproduce:
Open the sample DOCX in Word

Actual Results:
LibreOffice makes the first row taller to provide space for the enter symbol but there is no text so it is not necessary.

Expected Results:
The cell should keep its size 



Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_22:04:10
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

Also happens in:
Verzió: 6.2.5.2 (x86)
Build az.: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: GL; VCL: win; 
Területi beállítások: hu-HU (hu_HU); UI nyelve: hu-HU
Calc: 

But not in:

Version: 6.1.4.2
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: hu-HU (hu_HU); Calc: CL

Bibisected using bibisect-win32-6.2 to: 
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=49ddaad2f3ba4e17e1e41e94824fb94468d2b680 
author:  Justin Luth <justin.luth@collabora.com>	
committer: Miklos Vajna <vmiklos@collabora.co.uk> 
summary: writerfilter: IgnoreTabsAndBlanksForLineCalculation
Comment 1 NISZ LibreOffice Team 2019-09-18 08:31:49 UTC
Created attachment 154254 [details]
The example document in Word and Writer side by side.
Comment 2 NISZ LibreOffice Team 2019-09-18 08:32:05 UTC
Created attachment 154255 [details]
Example document from Word
Comment 3 NISZ LibreOffice Team 2019-09-18 08:33:21 UTC
Adding CC to Justin Luth
Comment 4 Dieter 2019-09-19 05:14:11 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: f0c832acb53326ccc9a8c1a47401fbc9e1081feb
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-11_05:46:53
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 5 Timur 2019-09-19 06:25:42 UTC
Created attachment 154278 [details]
Example compared MSO LO6.2 LO64+

Text is TNR 12 and enter without text is TNR 48.
Comment 6 Justin L 2019-09-24 12:38:50 UTC
(In reply to NISZ LibreOffice Team from comment #0)
> LibreOffice makes the first row taller to provide space for the enter symbol
> but there is no text so it is not necessary.
Not entirely accurate.  The last character in that cell is a space, size 48pt.

I thought this might be a compatibility level problem, but apparently not since MS Office 2016 also ignores that space character.
Comment 7 Justin L 2019-09-24 12:40:26 UTC
Created attachment 154432 [details]
The size of spaces is ignored.docx: created by MSOffice 2003, proves regression
Comment 8 Justin L 2019-09-25 07:43:15 UTC
The regressive patch is being reverted as far back as I can go. See bug 117988 for the status.
Comment 9 Xisco Faulí 2019-09-26 07:05:41 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 186d36a7036462ae641b35004b4ffba3eeeca46f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded