Download it now!
Bug 127632 - emf import takes more than 5 minutes
Summary: emf import takes more than 5 minutes
Status: RESOLVED DUPLICATE of bug 45820
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2019-09-19 02:53 UTC by nd101
Modified: 2019-09-19 20:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
MSO document (1.35 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-09-19 02:53 UTC, nd101
Details
EMF file extracted from PPTX document (8.84 MB, image/x-emf)
2019-09-19 07:48 UTC, Bartosz
Details
WinDbg ST against recent master on emfio filter insertion of EMF and earlier sample WMFs (14.84 KB, application/x-zip-compressed)
2019-09-19 20:18 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nd101 2019-09-19 02:53:25 UTC
Created attachment 154276 [details]
MSO document

late model computer,

Intel Xeon CPU E5-1620 v4 @ 3.50GHz
16G RAM

emf 9M uncompressed

PPTX document 1.3M
Comment 1 nd101 2019-09-19 02:54:32 UTC
maybe related to https://bugs.documentfoundation.org/show_bug.cgi?id=45820
Comment 2 Bartosz 2019-09-19 07:48:13 UTC
Created attachment 154282 [details]
EMF file extracted from PPTX document
Comment 3 nd101 2019-09-19 08:48:12 UTC
(In reply to Bartosz from comment #2)
> Created attachment 154282 [details]
> EMF file extracted from PPTX document

I see bug 45820 has been around since 2012.. It must be hard to solve.
Comment 4 V Stuart Foote 2019-09-19 20:17:25 UTC
Caolan and Thorsten left perf issues of bug 45820 unfinished when last visited--stack traces attached (the old WMF attachment 87291 [details] and attachment 60604 [details] from bug 45820; and attachment 154282 [details] from here--both OpenGL & Default GDI rendering) show we are still held up with parsing the clip polygons.

*** This bug has been marked as a duplicate of bug 45820 ***
Comment 5 V Stuart Foote 2019-09-19 20:18:26 UTC
Created attachment 154300 [details]
WinDbg ST against recent master on emfio filter insertion of EMF and earlier sample WMFs