Bug Hunting Session
Bug 127708 - Make it easier to revert to "No setting" for various settings of a style
Summary: Make it easier to revert to "No setting" for various settings of a style
Status: RESOLVED DUPLICATE of bug 89826
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-23 07:59 UTC by Eyal Rozenberg
Modified: 2019-10-09 09:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2019-09-23 07:59:58 UTC
When I have a character or paragraph style which includes a font size setting, and I want to remove that setting, e.g. only have a boldness setting, or a font family choice - this is difficult / not obvious / not possible to do.

It should be the case that if you erase the size in points in the combo box, it stays erased, to signify "no change". Instead, the minimum value of 2pt is is inserted when I try it.

It should perhaps also be possible to remove changes due to the character style from the Organizer pane of the Style dialog (The "Contains" listing).
Comment 1 Heiko Tietze 2019-09-25 08:32:23 UTC
Don't get it. Let's say you inherit a style from Default and set font size to 18. What exactly is difficult to revert? Just edit the style and set size to 12.

In the course of discussing bug 38194 we came up with the addition to selectively revert style properties. Guess this would solve your request.

*** This bug has been marked as a duplicate of bug 38194 ***
Comment 2 Eyal Rozenberg 2019-09-25 08:43:46 UTC
(In reply to Heiko Tietze from comment #1)
> Just edit the style and set size to 12.

But it's not 12. The Default character style is whatever size the paragraph style sets the font to.
Comment 3 Eyal Rozenberg 2019-09-25 08:46:24 UTC
(In reply to Heiko Tietze from comment #1)
> Don't get it.

Also, if you didn't understand exactly what the reporter meant, please extend them the courtesy of waiting for an explanation before closing the bug.

I know that impetus of closing bugs I'm supposed to address and are "on me", but still...
Comment 4 Heiko Tietze 2019-09-25 08:58:57 UTC
I have to admit that reverting a property remains in this exact value. And in some rare cases this may spoil the inheritance (eg. Default = 12, Default.Big = 12, after reverting it from 13, Default.Test.Bold... -> and .Bold would stay 12 even when Default changes).

But I'm against means to revert style properties by deleting the value. This procedure is not clear to the average user nor it is common. We should rather provide an option with the styles inspector, see bug 38194. Alternatively, a dedicated button on the property could also work transparently. But my take is still to make this a duplicate.
Comment 5 Regina Henschel 2019-09-25 10:28:49 UTC
@Eyal: To go back to the "inherit" mode use the "Standard" button in the dialog. To see, whether an attribute is set, use the "contains" section in the "Organizer" tab.

I agree with Eyal, the current UI is bad. If you are on a tab with settings:
you can not see, which of the attributes is inherited or not,
you cannot put a single attribute back to "inherit" mode,
you cannot set an attribute to the same value as the parent, but be not inherited,
you don't know, which of the attributes on a tab page will loose the "inherit" mode, when clicking on OK.

Currently the description of the "styles inspector" in bug 38194 does not contain, how to change an attribute value or to go back to "inherit" respectively. It is not clear, whether it will be a pure inspector or not.
Comment 6 Heiko Tietze 2019-09-27 07:14:00 UTC
(In reply to Regina Henschel from comment #5)
> Currently the description of the "styles inspector" in bug 38194 does not
> contain, how to change an attribute value or to go back to "inherit"
> respectively. It is not clear, whether it will be a pure inspector or not.

Talked with MikeK about this and planned to update the mockup with his ideas. My point is not the need to reset individual properties but where and how we place the interaction.
Comment 7 Eyal Rozenberg 2019-09-27 08:33:02 UTC
Adding a concrete suggestion:

It would help (though not fully resolve this issue IMHO), if  the different pieces of text in the "Contains" listing (under "Organize" in the style dialog) would be clickable (or right-clickable), with the click effecting a removal, i.e. a reversion to inheriting the setting.
Comment 8 Eyal Rozenberg 2019-09-27 08:42:53 UTC
(In reply to Regina Henschel from comment #5)
> @Eyal: To go back to the "inherit" mode use the "Standard" button in the
> dialog. To see, whether an attribute is set, use the "contains" section in
> the "Organizer" tab.

1. "Standard" does not seem to put things back in "inherit" mode.
2. Pressing "Standard" does not make various boxes unset in the dialog pane you're pressing it on.
3. "Standard" - if/when it works - regards all settings on a pane, I want to unset individual settings.
Comment 9 Heiko Tietze 2019-10-09 09:21:19 UTC
Bug 89826 requests the same and has a suggestion how to solve the issue.

*** This bug has been marked as a duplicate of bug 89826 ***