Bug Hunting Session
Bug 127744 - Find & Replace > Format dialog shows inch instead of local unit settings
Summary: Find & Replace > Format dialog shows inch instead of local unit settings
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Measurement-Units Find&Replace-Dialog
  Show dependency treegraph
 
Reported: 2019-09-24 13:24 UTC by Pit Zaclade
Modified: 2019-12-04 12:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pit Zaclade 2019-09-24 13:24:02 UTC
Description:
In the German Writer of Libre Office 6.2.7.1 (x64) (and AOO 4.1.5 too) with units "cm" I have got numbers with "inch" in the dialogue Find & Replace ->Format->Indent. Thats buggy.   

Steps to Reproduce:
1.(Only Writer in German!) Make a new writer document.
2. Write a little text with Liberation Serif 12.
3. Mark one sentence
4. Format→Paragraph→Indent→Before text: 1 cm (This shows us, that the units are „cm“)
5. Now Find & Replace→Liberation Serif→Indent -> and increase this (only one step is enough):
0,02 inch


Actual Results:
You get inch

Expected Results:
You get cm


Reproducible: Always


User Profile Reset: No



Additional Info:
If the units are cm (as in Germany is plausible and usually), than the indent in the search & file dialog can be only cm
Comment 1 Julien Nabet 2019-09-24 14:33:02 UTC
On Win10 with LO 6.3.1 + French UI (where I expect too "cm" and not "''" corresponding to inches), I could reproduce this.

I noticed that if I go to Format/paragraph, Indents & Spacing tab, there's "cm".
In addition, if I try to reproduce again the bug, without relaunching LO, I don't reproduce it !!
If I relaunch LO and just try to reproduce the bug, it appears again.

So it seems that Format/paragraph, Indents & Spacing tab calls a function which retrieves some localization config and the config is kept until we exit LO.
Comment 2 Xisco Faulí 2019-09-26 15:07:27 UTC
I can't reproduce it in

Versión: 6.3.1.2 (x86)
Id. de compilación: b79626edf0065ac373bd1df5c28bd630b4424273
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded
Comment 3 Xisco Faulí 2019-09-26 15:09:10 UTC
Ok, I can reproduce it if I go directly to Search and Replace - Format, but not if I go to Format - Paragraph first...
Comment 4 Julien Nabet 2019-09-26 15:12:04 UTC
(In reply to Xisco Faulí from comment #3)
> Ok, I can reproduce it if I go directly to Search and Replace - Format, but
> not if I go to Format - Paragraph first...

A bit like https://bugs.documentfoundation.org/show_bug.cgi?id=127744#c1 :-)
Comment 5 DM 2019-12-04 12:36:53 UTC
I've had this issue for a long time (I reported it but cannot find now - I must have had to recreate my id)
Basically (in Writer for me), Writer options - General - is set to centimetres, but shape properties (eg Line...) usually show values in inches. Repeating setting the options gives no improvement in the dialogues.
I say 'usually' because sometimes it randomly changes to centimetres mode, as it has just done this moment. It will in short course generally revert back to its usual inches in defiance of the option settings (and my windows settings are all for the UK), so it's not even consistent with the problem.
This is a very problematic issue for anyone dealing with sizes.
This has been going on since at least 6.3.?1 or 2-ish days, and is occurring on the latest beta:-

Version: 6.4.0.0.beta1 (x64)
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 2; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

d