Download it now!
Bug 127760 - Installation - pls keep my environment!
Summary: Installation - pls keep my environment!
Status: RESOLVED DUPLICATE of bug 76131
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Installer-Windows
  Show dependency treegraph
 
Reported: 2019-09-25 12:08 UTC by VistaMail1
Modified: 2019-09-26 09:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description VistaMail1 2019-09-25 12:08:26 UTC
Description:
I have writer and calc in my taskbar as icons. My most busy files are attached to these icons. It would be great, if there would be an option, these settings of attached files would be kept after installations of a new version of LieberOffice.

This would be great vor Writer as well as for all other components of Libreoffice. I want to use on my embedding of the software into the system as I am used to.

Steps to Reproduce:
1.configure some icons for LibreOffice in the taskbar
2.attach some files to it
3.install a new version of libre office
4.your confiuration is lost, although the installation is into exactly the same diretories

Actual Results:
4.your confiuration is lost, although the installation is into exactly the same diretories

Expected Results:
4.your configuration and icons are the same as they were


Reproducible: Always


User Profile Reset: No



Additional Info:
Save the environment of an Office Installation and restore it after an Update of LibreOrrice.
Comment 1 Roman Kuznetsov 2019-09-25 13:41:42 UTC
Mike, any opinions here?
Comment 2 V Stuart Foote 2019-09-25 14:02:16 UTC
No problems with Windows 7 Jump List configuration on version updates. Pinened Start Menu or Task Bar launchers and application specific list of recents are carried over. LO does _not_ clear that cache on update and LO profile held history is completely different.

Are you sure you have Windows Recent Items configured correctly [1]? Windows 10 UWP is not friendly to these Desktop features.


Otherwise => WFM

=-ref-=
[1]  https://www.tenforums.com/tutorials/3469-turn-off-recent-items-frequent-places-windows-10-a.html
Comment 3 Xisco Faulí 2019-09-25 14:59:18 UTC
(In reply to V Stuart Foote from comment #2)
> No problems with Windows 7 Jump List configuration on version updates.
> Pinened Start Menu or Task Bar launchers and application specific list of
> recents are carried over. LO does _not_ clear that cache on update and LO
> profile held history is completely different.
> 
> Are you sure you have Windows Recent Items configured correctly [1]? Windows
> 10 UWP is not friendly to these Desktop features.
> 
> 
> Otherwise => WFM
> 
> =-ref-=
> [1] 
> https://www.tenforums.com/tutorials/3469-turn-off-recent-items-frequent-
> places-windows-10-a.html

Setting to NEEDINFO
Comment 4 Mike Kaganski 2019-09-25 15:19:12 UTC

*** This bug has been marked as a duplicate of bug 76131 ***
Comment 5 VistaMail1 2019-09-26 08:57:34 UTC
This is not an issue of "frequent places"!
Frequent places and files are nice, but not very important.
So the link is interesting (thanks!), but not working in this case.

This is different:
Pls mind point 2 of "steps to reproduce":
It reads: "DRAG A FILE on the icon in the taskbar."

This dragging creates a list of links above the taskbar-icon. And this list may be really much of work, if you are used to organise your desktop this way. To collect your files again and re-attache them, - this is annoying to do it every 6.2.9. and 6.3.0 and 6.3.1.......... update again.

So please: SAVE this settings on installation and re-add them.
Comment 6 Mike Kaganski 2019-09-26 09:03:58 UTC
Please don't reopen the bug, which is the duplicate of the said bug.

The root of the problem is that the upgrade is a two-stage process, in which initially the older version of the program is uninstalled, and then newer one is reinstalled. In that process, LibreOffice doesn't (and can't) detect/save/restore any settings related to *Windows Explorer* (it's it that manages the list you ate talking about, not LibreOffice). When the first stage happens, the list becomes invalid, and then the newer installation isn't associated with that list by Explorer.

The possible solutions are the same as in the bug this one is marked duplicate of: either manage own pinned lists (implement a new functionality), or change uninstallation process.

*** This bug has been marked as a duplicate of bug 76131 ***
Comment 7 VistaMail1 2019-09-26 09:56:35 UTC
thank you for the explanation!