Bug 127764 - FILESAVE MPEG-4 Videos not exported to ppt/pptx
Summary: FILESAVE MPEG-4 Videos not exported to ppt/pptx
Status: VERIFIED DUPLICATE of bug 53970
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: dataLoss
Depends on:
Blocks: PPTX-OLE
  Show dependency treegraph
Reported: 2019-09-25 14:12 UTC by David Hoese
Modified: 2022-04-28 08:36 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:

Test video embedded into PowerPoint presentation (585.24 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-12-12 10:50 UTC, Chris Sherlock
Example video embedded in odp file (408.92 KB, application/vnd.oasis.opendocument.presentation)
2022-03-30 08:39 UTC, Gabor Kelemen (allotropia)
attachment 179202 saved in current nightly (395.74 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2022-03-30 11:23 UTC, Gabor Kelemen (allotropia)
attachment 179207 in PP and attachment 17920 in Impress (257.91 KB, image/png)
2022-03-30 11:39 UTC, Gabor Kelemen (allotropia)

Note You need to log in before you can comment on or make changes to this bug.
Description David Hoese 2019-09-25 14:12:38 UTC
I'm working on a presentation in Impress and noticed that when I save the presentation as a Powerpoint (.pptx) the video files that I've added are not included in the presentation. When I re-open the pptx file in Impress it has no reference to the video (not even a placeholder).

I've also tried running the conversion from the command line with "--convert-to pptx" and after unzipping and inspecting the created slides I don't see any reference to a video.

The videos are MPEG-4 (.mp4) that I created with ffmpeg. One of the videos is 2.1MB, the other is 725KB. I'm on PopOS (basically Ubuntu) with KDE and have LibreOffice 20(Build:1).

Note the videos are stored fine in .odp format.

This seems related to:

- https://bugs.documentfoundation.org/show_bug.cgi?id=106867
- https://bugs.documentfoundation.org/show_bug.cgi?id=34803
- https://bugs.documentfoundation.org/show_bug.cgi?id=84427

Steps to Reproduce:
1. Create new Impress presentation.
2. Add video file
3. Save as .pptx
4. Close and reopen .pptx and note missing video

Actual Results:
No videos saved to presentation

Expected Results:
Videos stay in the presentation and get saved/exported to the .pptx format.

Reproducible: Always

User Profile Reset: No

Additional Info:
Build ID: 1:6.2.7-0ubuntu0.19.04.1
CPU threads: 12; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-10-14 15:30:45 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 David Hoese 2019-10-14 19:19:41 UTC
Well now I can't get Impress (really gstreamer) to play my .mp4 videos at all (says I'm missing the quicktime plugin but I have all plugin packages installed). So although my presentation was a simple slide with a .mp4 video added, I'm not sure I should add it until I can get gstreamer to play the video.
Comment 3 QA Administrators 2019-10-15 02:30:16 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2019-12-06 11:47:47 UTC
I can repro with an MPEG-4 (Xvid) .avi with PPTX, but not PPT.

Arch Linux 64-bit
Build ID: 7e403195e574be5174815a51cf5c42f06f76a87a
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 1 December 2019
Comment 5 Buovjaga 2019-12-06 14:00:15 UTC
The commits toward bug 106867 should have fixed this, but now when I test while being checked out on the last commit, even the original test video disappears for me! Testing is done on Windows.

I can otherwise reproduce all the way to 4.4.7.

Testers can use attachment 132275 [details] as the video for testing (from bug 106867)
Comment 6 Xisco Faulí 2019-12-12 10:22:01 UTC
I can reproduce this issue since https://cgit.freedesktop.org/libreoffice/core/commit/?id=da4a5fa517a7379da84bf7d514eafe2c721246d3, when GStreamer version was bumped to 1.0 and I could then import the video in Impress
Comment 7 Xisco Faulí 2019-12-12 10:23:25 UTC
OTOH, is it possible to create such a file with MSO Powerpoint ?
I've just tried with MSO 2010 and it fails to import attachment 132275 [details]
Comment 8 Xisco Faulí 2019-12-12 10:35:00 UTC
(In reply to Xisco Faulí from comment #7)
> OTOH, is it possible to create such a file with MSO Powerpoint ?
> I've just tried with MSO 2010 and it fails to import attachment 132275 [details]
> [details]

Lowering severity/priority until this is confirmed
Comment 9 Chris Sherlock 2019-12-12 10:50:19 UTC
Created attachment 156504 [details]
Test video embedded into PowerPoint presentation

New PowerPoint presentation created, inserted the test video and saved as pptx.
Reopened this in PowerPoint and the video shows fine. 

Version: Microsoft PowerPoint for Mac, version 16.32 (19120802).
Comment 10 Chris Sherlock 2019-12-12 10:52:03 UTC
FWIW, LibreOffice Version: cannot play the video in the file I just uploaded (using MacOS Catalina).

Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Xisco Faulí 2019-12-12 10:56:12 UTC
This is interesting:
if I create a blank document, import the video file and the I save the document as PPTX, the issue is reproduced.
OTOH, if I open chris' attachment created with Office 365 on Mac and save it as PPTX again, the new document keeps the video
Comment 12 ffs 2020-09-08 09:59:08 UTC
This has just happened to me in

I can embed save and load video in ODP format but when I save in pptx or ppt the video vanishes.

In pptx there are no placeholders or anything.  In ppt there are placeholders but no video.

Recently I've had no problems until just now - it's quite annoying.
Comment 13 LPC 2020-11-09 11:13:48 UTC
Bug reproducible in both windows and linux versions of LO 7 and 6

windows 8.1 LO version (x64)
Ubuntu 18.04 LO version 7.0.1 and dev 7.1 alpha and also 6.something can't remember exactly (likely 6.4).

linking video also fails

Exporting to PPTX (every version above old PPT) will remove any user visible trace of the video (file size also smaller than ODP = video is gone) while exporting to PPT a video box is visible but the video isn't in the file (easily noticed by file size) and also when linked won't fetch it correctly/play.

Tried with MPG, WMV and MP4 always same result.

sidenote/bug: With MP4 while importing the file to LO Impress in LO (x64) in windows 8.1 there's this error: "The format of the selected file is not supported." . But importing .MPG works, yet exporting to PPTX or PPT will result in this bug.
Comment 14 Gabor Kelemen (allotropia) 2022-03-30 08:39:12 UTC Comment hidden (obsolete)
Comment 15 Xisco Faulí 2022-03-30 08:46:16 UTC
(In reply to Gabor Kelemen (allotropia) from comment #14)
> Created attachment 179202 [details]
> Example video embedded in odp file
> Still happens when a video is saved from ODP to PPTX.
> Only PPTX->PPTX roundtrip works (bug #106867)
> Version: / LibreOffice Community
> Build ID: 4a46a74a3de0ac7df5d3ce949dda5e809c1729ab
> CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
> Locale: hu-HU (hu_HU.UTF-8); UI: en-US
> Calc: threaded

Hi Gabor,
Could you please try with a recent build including the fix for bug 53970 ?
Comment 16 Gabor Kelemen (allotropia) 2022-03-30 11:23:24 UTC
Created attachment 179207 [details]
attachment 179202 [details] saved in current nightly

Now the MP4 save works, even opens correctly in PP 2013, in todays nightly

Version: (x64) / LibreOffice Community
Build ID: a3988b2d147a2442b348d58b79dbd6e71472b7af
CPU threads: 14; OS: Windows 10.0 Build 19044; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: threaded Jumbo
Comment 17 Gabor Kelemen (allotropia) 2022-03-30 11:39:11 UTC
Created attachment 179208 [details]
attachment  179207 [details] in PP and attachment 17920 in Impress

Impress on Windows does not play the video in odp, but saves a correct PPTX.
Comment 18 Timur 2022-04-05 11:32:24 UTC
Actually, since bug 53970 is WIP, ODP attachment 179207 [details] opens and plays in LO while it just opens in MSO and needs a manual click to start play, but that seems usual in MSO. 
Also MSO PPTX attachment 156504 [details] resaved well.
So this bug seems duplicate of 53970 for PPTX. 
PPT will need another clear bug.

*** This bug has been marked as a duplicate of bug 53970 ***
Comment 19 NISZ LibreOffice Team 2022-04-28 08:36:19 UTC
The attached video file stay in the presentation like a preview image in Impress, but isn't playable like PowerPoint after save as .pptx.
LibreOffice doesn't support this file format playable showing.
The file export/import work correctly, so the bug fixed. 

Under Windows OS I can't atteched an mp4 file because this file format isn't supported.

Verified in:
Version: / LibreOffice Community
Build ID: 5453f75a1e682992f3a725781bb563b8cc76cf1b
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded