Bug 127789 - unexpected err :522 since Calc 6.3.0.4
Summary: unexpected err :522 since Calc 6.3.0.4
Status: RESOLVED DUPLICATE of bug 124270
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-09-26 13:07 UTC by guillaume.ameline
Modified: 2019-09-28 09:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
This file is not properly calculated since Calc 6.3.0.4 (8.38 MB, application/vnd.oasis.opendocument.spreadsheet)
2019-09-26 13:09 UTC, guillaume.ameline
Details

Note You need to log in before you can comment on or make changes to this bug.
Description guillaume.ameline 2019-09-26 13:07:28 UTC
Description:
My Calc project worked just fine until LibreOffice 6.2.7.1, but from 6.3.0.4 to 6.3.2.2, The most important curve can not be displayed anymore, because somethig goes wrong in some "iterative" calculus.

Steps to Reproduce:
Open the file "Modelisation trajectoire aeronef avec vent.ods" with Calc 6.3.0.4 or newer.

Actual Results:
In FiltrageVent sheet, observe all "err :522" on columns H,I,K etc...

Expected Results:
I expected the same result as when opening the file with Calc 6.2.7.1 or older.


Reproducible: Always


User Profile Reset: No



Additional Info:
With Calc 6.3.0.4, I have already been able to make the calculus temporarily work again, by copying several times the cells down columns G,H,Y, or up column DN, from FiltrageVent sheet. But saving and opening again the file brought back the errors.

I wish I was able to norrow down the problem to something more precise, but that is all I can say so far.
Comment 1 guillaume.ameline 2019-09-26 13:09:48 UTC
Created attachment 154545 [details]
This file is not properly calculated since Calc 6.3.0.4
Comment 2 Xisco Faulí 2019-09-26 14:36:24 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=906b505940f6330d2336164f341e338ff4b9b9ee

author	Luboš Luňák <l.lunak@collabora.com>	2019-01-25 15:08:16 +0100
committer	Luboš Luňák <l.lunak@collabora.com>	2019-01-28 11:01:06 +0100
commit	906b505940f6330d2336164f341e338ff4b9b9ee (patch)
tree	87de1e848215c0c0cfb22017fd859d807e87f482
parent	6f5991261a152812d5023fd146398c1528683676 (diff)
avoid a calc threads assert because of an undetected cyclic dependency

Bisected with: bibisect-linux64-6.3

Adding Cc: to Luboš Luňák
Comment 3 Xisco Faulí 2019-09-26 14:45:08 UTC
The problem is not happening if you disable calculation threading.
Tools - Options - LibreOffice Calc - Calculate
Comment 4 Xisco Faulí 2019-09-26 14:45:25 UTC
Actually it's a duplicate of bug 124270

*** This bug has been marked as a duplicate of bug 124270 ***
Comment 5 guillaume.ameline 2019-09-26 17:08:50 UTC
Indeed, disabling multithreaded calculations removes the "Err :522", but the calculations become wrong, with an unstable result...

Thank you Xisco Fauli, for these steps forward.
Comment 6 b. 2019-09-27 18:12:08 UTC
repro with 6.3.0.0alpha1+, nonrepro with 6.2.7.1, but also the second is not 'bugfree'. 

hello guillaume, 

!respect! - huge project, 

my suggestions: 

while not fixed go back to 6.2.7.1, it's the most stable version i've seen yet, 

(since 4.1.6.2) 

also try to use it 'unthreaded', i had - very rare - 'err:522' and 'stuck calculations' (values not updated unless 'hard recalc') also in this version when 'threaded', 

avoid doing productive work with 'dev' versions, i learned it the hard way :-( 

(but i hope my problems contributed to the overall quality of the program)

reg. 



b.
Comment 7 guillaume.ameline 2019-09-27 20:26:44 UTC
Thank you b, that is all very well said.

I did go back to 6.2.7.1, with backups and all that. And I will keep your advice in mind, if I see strange results. It probably happened already, but the project seems to be quite stable now, even with threaded calculations enabled.

I only tried 'dev' versions so that my reports can be as accurate as possible. And I mainly use Linux to work on this project...

Best tegards,

Guilaume

(In reply to b. from comment #6)
> repro with 6.3.0.0alpha1+, nonrepro with 6.2.7.1, but also the second is not
> 'bugfree'. 
> 
> hello guillaume, 
> 
> !respect! - huge project, 
> 
> my suggestions: 
> 
> while not fixed go back to 6.2.7.1, it's the most stable version i've seen
> yet, 
> 
> (since 4.1.6.2) 
> 
> also try to use it 'unthreaded', i had - very rare - 'err:522' and 'stuck
> calculations' (values not updated unless 'hard recalc') also in this version
> when 'threaded', 
> 
> avoid doing productive work with 'dev' versions, i learned it the hard way
> :-( 
> 
> (but i hope my problems contributed to the overall quality of the program)
> 
> reg. 
> 
> 
> 
> b.