Download it now!
Bug 127820 - FILEOPEN DOCX Chart anchored to table cell appears inside the cell
Summary: FILEOPEN DOCX Chart anchored to table cell appears inside the cell
Status: RESOLVED DUPLICATE of bug 128207
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2019-09-27 10:42 UTC by NISZ LibreOffice Team
Modified: 2020-01-10 13:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Word (31.24 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-09-27 10:43 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer. (81.65 KB, image/png)
2019-09-27 10:47 UTC, NISZ LibreOffice Team
Details
Example ODT file from Writer. (18.30 KB, application/binary)
2019-09-27 10:47 UTC, NISZ LibreOffice Team
Details
The original file saved by Writer - there is an export problem too (17.92 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-09-27 10:48 UTC, NISZ LibreOffice Team
Details
Screenshot of the original odt and exported docx document side by side in Writer (56.39 KB, image/png)
2019-09-27 10:49 UTC, NISZ LibreOffice Team
Details
ItSeemsToBeFixedIn6.5 (117.35 KB, image/png)
2020-01-10 12:57 UTC, Attila Bakos (NISZ)
Details
ThisIsFixedToo (120.96 KB, image/png)
2020-01-10 13:00 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-09-27 10:42:35 UTC
Description:
Attached user made document contains a simple table with a small pie chart next to it, but anchored to the top right cell of the table.
In Writer this chart appears inside the top right table cell instead of next to the table.

It is possible to create such a layout in Writer and save it to ODT, but on save to DOCX the chart appears inside the table cell as well.

Steps to Reproduce:
    1. To create a similar document in Writer insert a simple table
    2. Create a pie chart
    3. Move the pie chart until its anchor appears inside one of the table cells

Actual Results:
The chart appears inside the table cell it was originally anchored.

Expected Results:
The chart stays anchored to the table but appears next to it.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 5440274a2a295fb2662ea415f25b89fc298930c8
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-09-26_01:04:59
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

The problem happens in 4.2 too, before the chart did not show at all.
Comment 1 NISZ LibreOffice Team 2019-09-27 10:43:05 UTC
Created attachment 154586 [details]
Example file from Word
Comment 2 NISZ LibreOffice Team 2019-09-27 10:47:08 UTC
Created attachment 154587 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 3 NISZ LibreOffice Team 2019-09-27 10:47:55 UTC
Created attachment 154588 [details]
Example ODT file from Writer.
Comment 4 NISZ LibreOffice Team 2019-09-27 10:48:30 UTC
Created attachment 154589 [details]
The original file saved by Writer - there is an export problem too
Comment 5 NISZ LibreOffice Team 2019-09-27 10:49:01 UTC
Created attachment 154590 [details]
Screenshot of the original odt and exported docx document side by side in Writer
Comment 6 raal 2019-09-28 16:31:19 UTC
Confirm with Version: 6.4.0.0.alpha0+
Build ID: 186d36a7036462ae641b35004b4ffba3eeeca46f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 7 Xisco Faulí 2019-09-30 13:34:56 UTC
Also reproducible in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8


Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

in previous versions the chart is not even displayed
Comment 8 Attila Bakos (NISZ) 2020-01-10 12:57:08 UTC
Created attachment 157064 [details]
ItSeemsToBeFixedIn6.5
Comment 9 Attila Bakos (NISZ) 2020-01-10 12:57:44 UTC

*** This bug has been marked as a duplicate of bug 128207 ***
Comment 10 Attila Bakos (NISZ) 2020-01-10 13:00:05 UTC
Created attachment 157065 [details]
ThisIsFixedToo