Download it now!
Bug 127919 - Assign Component dialog F1/Help button behave inconsistently
Summary: Assign Component dialog F1/Help button behave inconsistently
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords:
Depends on:
Blocks: Macro-UI 127604
  Show dependency treegraph
 
Reported: 2019-10-02 07:30 UTC by LibreOfficiant
Modified: 2019-12-12 16:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LibreOfficiant 2019-10-02 07:30:53 UTC
Description:
"Dialog Editor - Assign Action" dialog holds a 'Component' button whose dialog help routes to "Basic" main help page.


Actual Results:
 

Expected Results:
Ideally the "Assign Component" dialog help page should point to 
   text/shared/01/06140500.html
or
   text/sbasic/python/python_handler.html


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-12-11 12:58:05 UTC
Hello LibreOfficiant,
Could you please explain how to reach the desired dialog ?
Comment 2 LibreOfficiant 2019-12-11 14:17:26 UTC
From LibO Launcher:
Tools - Macros - Organize dialogs…

Once in 'LibO Basic Macro Organizer dialog':
(Dialogs) - LibO Dialogs - Access2Base - dlgTrace - Edit it!

1. Select/click any control in the dialog panel to activate bottom/left properties panel e.g. 'OK' button who appears to be named 'cmdOK' 
2. Select/click 'Events' tab within Properties panel
3. Select/click any event '…' button to get the… 

…'Assign Action' dialog who should exhibit 'Macro…' and 'Component…' buttons

- When 'Component…' button  has focus and F1 is pressed
  or
- When 'Assign Component' subsequent dialog is displayed

target help page should be:
https://help.libreoffice.org/6.4/en-US/text/shared/01/06140500.html?DbPAR=BASIC
Comment 3 Xisco Faulí 2019-12-11 14:24:01 UTC
I do reproduce that help button in 'Assign Component' dialog opens: https://help.libreoffice.org/6.5/en-US/text/sbasic/shared/main0601.html?System=UNIX&DbPAR=BASIC

Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: b9d6ea1dd7541c4bd866571f9e3f0aa894687c07
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-12-11 14:24:29 UTC
I don't think it's an enhancement but a normal bug
Comment 5 Xisco Faulí 2019-12-11 14:27:24 UTC
@Caolán, since you recently fixed bug 129321, I thought you might be interested in this one a well...
Comment 6 LibreOfficiant 2019-12-11 14:42:51 UTC
(In reply to Xisco Faulí from comment #4)
> I don't think it's an enhancement but a normal bug

t'was an enhancement until I updated help </wink>
Comment 7 Caolán McNamara 2019-12-12 16:04:34 UTC
This seems to boil down to...

"make Assign Compoment dialog help point to  text/sbasic/python/python_handler.html"

taking it on that basis
Comment 8 Commit Notification 2019-12-12 16:06:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/08fa68db86928852e7b025b76059fcceceedf325

tdf#127919 link Assign Component dialog to 'Creating A Dialog Handler'
Comment 9 Commit Notification 2019-12-12 16:10:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/help/commit/54335ce48cca4ab26112f700210ecbe5fa5a0595

tdf#127919 link Assign Component dialog to 'Creating A Dialog Handler'