Download it now!
Bug 128152 - Bibliography entries hide after saving and reopening of the document
Summary: Bibliography entries hide after saving and reopening of the document
Status: RESOLVED DUPLICATE of bug 128845
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2019-10-15 10:57 UTC by Karel Hruska
Modified: 2019-12-04 13:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of entered bibliography but blank dropdown list (154.12 KB, image/png)
2019-10-15 10:58 UTC, Karel Hruska
Details
Document with four bibliography entries, list of bibliography and randomly copied bibliography entries (11.88 KB, application/vnd.oasis.opendocument.text)
2019-10-15 11:00 UTC, Karel Hruska
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karel Hruska 2019-10-15 10:57:38 UTC
Description:
After adding bibliography entries to a Writer document the bibliography entries hide after saving and reopening the file. The references into the text and the list of bibliography remain, but when trying to recall already added entries from the dropdown menu, the list is blank.

As an after-effect you can copy multiple times bibliography entry into the text and after refreshing the bibliography list it appears as many times as insterted into the text (needs saving and reopening the document).

Steps to Reproduce:
1. Insert some bibliography entries into the text (either copy & paste from other document or brand new).
2. Create bibliography list.
3. Save the document.
4. Open the document.
5. Try to add bibliography entry from the document database - the dropdown list is empty.
6. Randomly copy your entries through the text.
7. Save document.
8. Open document.
9. Refresh bibliography list - it shows each entry as many times as copied through the document.

Actual Results:
Empty list of document bibliography althrough these entries apparently exist within the document (the bibliography list sees and refreshes them).

Expected Results:
Dropdown list should show bibliography entries from the document database.

Bibliography list should show each item only once, not multiple times.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Karel Hruska 2019-10-15 10:58:35 UTC
Created attachment 155017 [details]
Screenshot of entered bibliography but blank dropdown list
Comment 2 Karel Hruska 2019-10-15 11:00:04 UTC
Created attachment 155018 [details]
Document with four bibliography entries, list of bibliography and randomly copied bibliography entries
Comment 3 Dieter Praas 2019-10-17 07:06:50 UTC
I confirm it with

Version: 6.3.3.1 (x64)
Build-ID: f41f4c7f9507aeca13cb9df51f34d80e8ba30a99
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded


Shorter steps to reproduce:
1. Create bibliography entry (Insert => indexes => biliography entry => new)
2. Short name is displayed in short name list => Insert
3. Create bibliography => bibliography entry is shown
4. Insert => indexes => bibliography entry => short name list is empty

Related to bug 127455, perhaps a duplicate, because I can't reproduce it with

Version: 6.1.6.3 (x64)
Build ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: group threaded
Comment 4 Xisco Faulí 2019-12-04 13:25:12 UTC
This is a duplicate of bug 128845

*** This bug has been marked as a duplicate of bug 128845 ***