Download it now!
Bug 128164 - Customisable "Tabbed" user interface
Summary: Customisable "Tabbed" user interface
Status: RESOLVED DUPLICATE of bug 101513
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2019-10-16 03:59 UTC by Matþew T. scarbrough
Modified: 2019-10-16 05:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matþew T. scarbrough 2019-10-16 03:59:38 UTC
First of all, I would like to thank the team for implementing the tabbed U.I., I am aware that many people did not like the implementation, but I believe it was a good idea. That being said, I think it would be better if it could be customisable and have the ability to import/export scripts that are responsible for handling the layout of the tabbed interface.

To be most clear, what I am referring to is the ability to add/remove custom tabs beyond the eight default, as well as customising the 8 default. The tabbed UI, or "not-ribbon," does a good job at mimicking the MS Office Ribbon, however, some shortcuts are missing from it that may be on the default, such as the ability to insert a drop cap from the Insert Tab.

Thank you.
Comment 1 V Stuart Foote 2019-10-16 05:54:09 UTC
With work during 2019 GSOC The MUFFIN Notebook Bar can already be 'customized'

Current master toward a 6.4.0 release
Tools -> Customize -> 'Notebook Bar' tab

You can test with current daily builds [1]

Not as flexible as Toolbar customization, but more so than Sidebar Decks which can also be 'customized' but must be done as scripts.

Adjusting commands in the Glade .UI configuration that are defined as .uno: can already be done (by script, with Glade, or via the new Tools -> Customize dialog).

Also, please note that in LibreOffice there is no Drop Cap command. An individual character can be styled or direct formatted for the effect. Or better, is to insert a Draw Text box holding the styled character(s), anchored 'as character' at the start of a paragraph.

=-ref-=
[1] https://dev-builds.libreoffice.org/daily/master/

*** This bug has been marked as a duplicate of bug 101513 ***