Download it now!
Bug 128207 - FILEOPEN: DOCX: Charts with absolute position are displayed on top of each other
Summary: FILEOPEN: DOCX: Charts with absolute position are displayed on top of each other
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:6.5.0 target:6.4.1
Keywords: bibisected, bisected, filter:docx
: 119041 123614 127820 (view as bug list)
Depends on:
Blocks: DOCX-Anchor-and-Text-Wrap docx-aggressive-competitors
  Show dependency treegraph
 
Reported: 2019-10-17 12:04 UTC by Xisco Faulí
Modified: 2020-04-20 12:42 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (49.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-10-17 12:04 UTC, Xisco Faulí
Details
comparison MSO 2010 and LibreOffice 6.4 Master (66.19 KB, image/png)
2019-10-17 12:06 UTC, Xisco Faulí
Details
afterFix (169.66 KB, image/png)
2020-01-10 12:52 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-10-17 12:04:37 UTC
Created attachment 155078 [details]
sample file

Steps to reproduce:
1. Open attached file

-> The charts are on top of each other. See comparison image

Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: 01d28b0b85f99590c0581e4bbf636bc9281e0571
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-10-17 12:06:23 UTC
Created attachment 155079 [details]
comparison MSO 2010 and LibreOffice 6.4 Master
Comment 2 Xisco Faulí 2019-10-17 12:09:39 UTC
After https://cgit.freedesktop.org/libreoffice/core/commit/?id=10efab2b9a3cf7fc49655c90ba29db4512680c38, the chart started to be displayed on top of each other, before that, they were displayed one after the other, with a wrong position anyway.

@Miklos, I thought you might be interested in this issue...
Comment 3 Aron Budea 2019-10-18 01:17:24 UTC
Confirmed with LO 6.4.0.0.alpha0+ (bb6bcabda53dbd64dda43f09fab9f4ad6f34eba6) / Windows.
Comment 4 Commit Notification 2020-01-10 12:09:16 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d9c535ead688e9f156dbcf43948df08a69e218be

tdf#128207: DOCX import: fix chart positioning

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2020-01-10 12:44:02 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: d9c535ead688e9f156dbcf43948df08a69e218be
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Bakos, thanks for fixing this issue! Should it be closed as RESOLVED FIXED ?
Comment 6 Attila Bakos (NISZ) 2020-01-10 12:52:31 UTC
Created attachment 157062 [details]
afterFix
Comment 7 Attila Bakos (NISZ) 2020-01-10 12:53:47 UTC
(In reply to Xisco Faulí from comment #5)
> Verified in
> 
> Version: 6.5.0.0.alpha0+
> Build ID: d9c535ead688e9f156dbcf43948df08a69e218be
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> @Bakos, thanks for fixing this issue! Should it be closed as RESOLVED FIXED ?

yes of course, I so slow because I do many thing simultaneously now... :)
Comment 8 Attila Bakos (NISZ) 2020-01-10 12:57:44 UTC
*** Bug 127820 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2020-01-13 11:28:57 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/4fcc04d134644a3013df7f331fe36072b96adb9f

tdf#128207: DOCX import: fix chart positioning

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Timur 2020-01-13 16:30:27 UTC
Please comment on backport to 6.3, if it is safe enough.
Comment 11 Attila Bakos (NISZ) 2020-01-14 10:11:48 UTC
(In reply to Timur from comment #10)
> Please comment on backport to 6.3, if it is safe enough.

I think it might worth a test.
Comment 12 Attila Bakos (NISZ) 2020-02-28 09:41:01 UTC
*** Bug 119041 has been marked as a duplicate of this bug. ***
Comment 13 NISZ LibreOffice Team 2020-04-20 12:42:46 UTC
*** Bug 123614 has been marked as a duplicate of this bug. ***